diff options
author | Maximilian Hils <git@maximilianhils.com> | 2015-12-03 17:56:57 +0100 |
---|---|---|
committer | Maximilian Hils <git@maximilianhils.com> | 2015-12-03 17:56:57 +0100 |
commit | 4718f36379c651e50a0e63954abfea8433ef514d (patch) | |
tree | dc61b08b65b4a66df31d95edd56316cd8e651d4c /setup.py | |
parent | 9f224f7dbd52b02421d0b3674b2630df6afa0007 (diff) | |
download | mitmproxy-4718f36379c651e50a0e63954abfea8433ef514d.tar.gz mitmproxy-4718f36379c651e50a0e63954abfea8433ef514d.tar.bz2 mitmproxy-4718f36379c651e50a0e63954abfea8433ef514d.zip |
use version specifiers compatible with old setuptools releases
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 18 |
1 files changed, 9 insertions, 9 deletions
@@ -15,17 +15,17 @@ with open(os.path.join(here, 'README.rst'), encoding='utf-8') as f: long_description = f.read() deps = { - "pyasn1~=0.1.9", - "pyOpenSSL~=0.15.1", - "cryptography~=1.1.0", - "passlib~=1.6.5", - "hpack~=2.0.1", - "six~=1.10.0", - "certifi>=2015.9.6.2", # no semver here - this should always be on the last release! - "backports.ssl_match_hostname~=3.4.0.2", + "pyasn1>=0.1.9, <0.2", + "pyOpenSSL>=0.15.1, <0.16", + "cryptography>=1.1.1, <1.2", + "passlib>=1.6.5, <1.7", + "hpack>=2.0.1, <2.1", + "six>=1.10.0, <1.11", + "certifi>=2015.9.6.2", # no semver here - this should always be on the last release! + "backports.ssl_match_hostname>=3.4.0.2, <3.4.1", } if sys.version_info < (3, 0): - deps.add("ipaddress~=1.0.15") + deps.add("ipaddress>=1.0.15, <1.1") setup( name="netlib", |