aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Kriechbaumer <Kriechi@users.noreply.github.com>2016-02-01 20:28:14 +0100
committerThomas Kriechbaumer <Kriechi@users.noreply.github.com>2016-02-01 20:28:14 +0100
commit81b32cf42629dcbe8f59633dcb9b62816b781968 (patch)
treea0aa45506d52dc1cd273b77997022d04e7338f12 /setup.py
parent1e203401261ab6b24ae193f81dc4256854de13d8 (diff)
parente98c729bb9b0d3debde6f61c948108bdc9dbafbe (diff)
downloadmitmproxy-81b32cf42629dcbe8f59633dcb9b62816b781968.tar.gz
mitmproxy-81b32cf42629dcbe8f59633dcb9b62816b781968.tar.bz2
mitmproxy-81b32cf42629dcbe8f59633dcb9b62816b781968.zip
Merge pull request #116 from Kriechi/hyperframe
migrate to hyperframe
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 2da10baa..e842fd74 100644
--- a/setup.py
+++ b/setup.py
@@ -17,11 +17,12 @@ with open(os.path.join(here, 'README.rst'), encoding='utf-8') as f:
deps = {
"pyasn1>=0.1.9, <0.2",
"pyOpenSSL>=0.15.1, <0.16",
- "cryptography>=1.2.1, <1.3",
+ "cryptography>=1.2.2, <1.3",
"passlib>=1.6.5, <1.7",
- "hpack>=2.0.1, <2.1",
+ "hpack>=2.0.1, <3.0",
+ "hyperframe>=3.1.1, <4.0",
"six>=1.10.0, <1.11",
- "certifi>=2015.9.6.2", # no semver here - this should always be on the last release!
+ "certifi>=2015.11.20.1", # no semver here - this should always be on the last release!
"backports.ssl_match_hostname>=3.5.0.1, <3.6",
}
if sys.version_info < (3, 0):
@@ -63,6 +64,7 @@ setup(
"pytest>=2.8.0",
"pytest-xdist>=1.13.1",
"pytest-cov>=2.1.0",
+ "pytest-timeout>=1.0.0",
"coveralls>=0.4.1",
"autopep8>=1.0.3",
"autoflake>=0.6.6",