aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAldo Cortesi <aldo@nullcube.com>2016-12-05 07:18:53 +1300
committerAldo Cortesi <aldo@nullcube.com>2016-12-08 10:21:06 +1300
commitd74cac265a9d1d8ce176a7ef96be2d91c4f40819 (patch)
tree47187e9cb00b4eea5060006ce0c7382fc41ac2d0 /setup.py
parentc94cd512d108fd9a12c87015791ce977b895fa2d (diff)
downloadmitmproxy-d74cac265a9d1d8ce176a7ef96be2d91c4f40819.tar.gz
mitmproxy-d74cac265a9d1d8ce176a7ef96be2d91c4f40819.tar.bz2
mitmproxy-d74cac265a9d1d8ce176a7ef96be2d91c4f40819.zip
Add YAML serialization of options
This uses ruamel.yaml. The library seems well-supported, and can do in-place modification of config files that retains user comments and file structure.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 56ba46fc..35f7edb3 100644
--- a/setup.py
+++ b/setup.py
@@ -79,6 +79,7 @@ setup(
"pyparsing>=2.1.3, <2.2",
"pyperclip>=1.5.22, <1.6",
"requests>=2.9.1, <3",
+ "ruamel.yaml>=0.13.2, <0.14",
"tornado>=4.3, <4.5",
"urwid>=1.3.1, <1.4",
"watchdog>=0.8.3, <0.9",