diff options
author | Maximilian Hils <git@maximilianhils.com> | 2017-12-30 22:29:49 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2017-12-30 22:29:49 +0100 |
commit | d9d4d15ee0c27dda0de340716b5275d4d444d0b8 (patch) | |
tree | f933f5dc1d508a3a53375e2a5aebf01b1627b762 /setup.py | |
parent | afe6e587f9d5423cfdf3710672d3886cc2753cd6 (diff) | |
parent | 2f150220e6da495fecf3ed66d5fedeed62d0f915 (diff) | |
download | mitmproxy-d9d4d15ee0c27dda0de340716b5275d4d444d0b8.tar.gz mitmproxy-d9d4d15ee0c27dda0de340716b5275d4d444d0b8.tar.bz2 mitmproxy-d9d4d15ee0c27dda0de340716b5275d4d444d0b8.zip |
Merge pull request #2733 from mitmproxy/pyinstaller
Update PyInstaller, add dev version info to builds.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -1,7 +1,7 @@ import os -import runpy from codecs import open +import re from setuptools import setup, find_packages # Based on https://github.com/pypa/sampleproject/blob/master/setup.py @@ -12,7 +12,8 @@ here = os.path.abspath(os.path.dirname(__file__)) with open(os.path.join(here, 'README.rst'), encoding='utf-8') as f: long_description = f.read() -VERSION = runpy.run_path(os.path.join(here, "mitmproxy", "version.py"))["VERSION"] +with open(os.path.join(here, "mitmproxy", "version.py")) as f: + VERSION = re.search(r'VERSION = "(.+?)(?:-0x|")', f.read()).group(1) setup( name="mitmproxy", |