aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--pathod/language/http2.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/pathod/language/http2.py b/pathod/language/http2.py
index 4d2ae198..ea4fcd27 100644
--- a/pathod/language/http2.py
+++ b/pathod/language/http2.py
@@ -262,7 +262,7 @@ class Request(_HTTP2Message):
else:
path = self.path.string()
if self.nested_response:
- path += self.nested_response.parsed.spec()
+ path += self.nested_response.parsed.spec().encode()
headers = Headers([header.values(settings) for header in self.headers])