aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.travis.yml11
-rw-r--r--README.mkd6
-rw-r--r--setup.py2
3 files changed, 15 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 7c4dca92..a2e8d5ff 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,9 +1,11 @@
language: python
+sudo: false
python:
- "2.7"
+ - pypy
# command to install dependencies, e.g. pip install -r requirements.txt --use-mirrors
-install:
- - "pip install --src .. -r requirements.txt"
+install:
+ - "pip install --src . -r requirements.txt"
# command to run tests, e.g. python setup.py test
script:
- "nosetests --with-cov --cov-report term-missing"
@@ -15,4 +17,7 @@ notifications:
- "irc.oftc.net#mitmproxy"
on_success: change
on_failure: always
-
+cache:
+ directories:
+ - /home/travis/virtualenv/python2.7.9/lib/python2.7/site-packages
+ - /home/travis/virtualenv/pypy-2.5.0/site-packages \ No newline at end of file
diff --git a/README.mkd b/README.mkd
index 7c96d396..79e7f803 100644
--- a/README.mkd
+++ b/README.mkd
@@ -1,4 +1,8 @@
-[![Build Status](https://travis-ci.org/mitmproxy/netlib.png?branch=master)](https://travis-ci.org/mitmproxy/netlib) [![Coverage Status](https://coveralls.io/repos/mitmproxy/netlib/badge.png?branch=master)](https://coveralls.io/r/mitmproxy/netlib)
+[![Build Status](https://travis-ci.org/mitmproxy/netlib.svg?branch=master)](https://travis-ci.org/mitmproxy/netlib)
+[![Coverage Status](https://coveralls.io/repos/mitmproxy/netlib/badge.svg?branch=master)](https://coveralls.io/r/mitmproxy/netlib)
+[![Latest Version](https://pypip.in/version/netlib/badge.svg?style=flat)](https://pypi.python.org/pypi/netlib)
+[![Supported Python versions](https://pypip.in/py_versions/netlib/badge.svg?style=flat)](https://pypi.python.org/pypi/netlib)
+[![Supported Python implementations](https://pypip.in/implementation/netlib/badge.svg?style=flat)](https://pypi.python.org/pypi/netlib)
Netlib is a collection of network utility classes, used by the pathod and
mitmproxy projects. It differs from other projects in some fundamental
diff --git a/setup.py b/setup.py
index f6f8907c..8e3d51b8 100644
--- a/setup.py
+++ b/setup.py
@@ -26,6 +26,8 @@ setup(
"Operating System :: POSIX",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Internet",
"Topic :: Internet :: WWW/HTTP",
"Topic :: Internet :: WWW/HTTP :: HTTP Servers",