aboutsummaryrefslogtreecommitdiffstats
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini27
1 files changed, 26 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 5d881ca9..3f8040d7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,10 +4,11 @@ skipsdist = True
toxworkdir={env:TOX_WORK_DIR:.tox}
[testenv]
+basepython = python3.5
deps =
{env:CI_DEPS:}
-rrequirements.txt
-passenv = CODECOV_TOKEN CI CI_* TRAVIS TRAVIS_* APPVEYOR APPVEYOR_*
+passenv = CODECOV_TOKEN CI CI_* TRAVIS TRAVIS_* APPVEYOR APPVEYOR_* SNAPSHOT_*
setenv = HOME = {envtmpdir}
commands =
mitmdump --sysinfo
@@ -29,3 +30,27 @@ commands =
mitmproxy/proxy/protocol/ \
mitmproxy/log.py \
mitmproxy/tools/dump.py mitmproxy/tools/web
+
+[testenv:wheel]
+recreate = True
+deps =
+commands =
+ python setup.py -q bdist_wheel --dist-dir release/dist
+ pip install {posargs} release/dist/mitmproxy-{env:VERSION:}-py3-none-any.whl
+ # skip `mitmproxy --version` if SKIP_MITMPROXY is defined.
+ {env:SKIP_MITMPROXY:mitmproxy --version}
+ mitmdump --version
+ mitmweb --version
+ pathod --version
+ pathoc --version
+
+[testenv:rtool]
+deps =
+ -rrequirements.txt
+ -e./release
+ # The 3.2 release is broken 🎉
+ # the next commit after this updates the bootloaders, which then segfault! 🎉
+ # https://github.com/pyinstaller/pyinstaller/issues/2232
+ git+https://github.com/pyinstaller/pyinstaller.git@483c819d6a256b58db6740696a901bd41c313f0c
+commands =
+ rtool {posargs}