aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Ding <victording@google.com>2020-10-26 18:40:07 +1100
committerEdward O'Callaghan <quasisec@chromium.org>2020-10-27 00:51:38 +0000
commit6d69c182da21d2b43d0f4c019efcb9d4de470328 (patch)
tree70c59bc464a580e85deb90a285856f86f15f562e
parent06ca247d65404c83143d4541984f3e7902be40e8 (diff)
downloadflashrom-6d69c182da21d2b43d0f4c019efcb9d4de470328.tar.gz
flashrom-6d69c182da21d2b43d0f4c019efcb9d4de470328.tar.bz2
flashrom-6d69c182da21d2b43d0f4c019efcb9d4de470328.zip
Mark ENE_LPC and MEC1308 as NEED_RAW_ACCESS
Both use INB/OUTB and hence should be marked as NEED_RAW_ACCESS in the makefile. Signed-off-by: Victor Ding <victording@google.com> Change-Id: I6fafd9f59d06f60e9491e3e059c1205d48d8232e Reviewed-on: https://review.coreboot.org/c/flashrom/+/46811 Reviewed-by: Edward O'Callaghan <quasisec@chromium.org> Reviewed-by: Angel Pons <th3fanbus@gmail.com> Tested-by: build bot (Jenkins) <no-reply@coreboot.org>
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 8af70428..3a0748c2 100644
--- a/Makefile
+++ b/Makefile
@@ -898,11 +898,13 @@ endif
ifeq ($(CONFIG_ENE_LPC), yes)
FEATURE_CFLAGS += -D'CONFIG_ENE_LPC=1'
PROGRAMMER_OBJS += ene_lpc.o
+NEED_RAW_ACCESS += CONFIG_ENE_LPC
endif
ifeq ($(CONFIG_MEC1308), yes)
FEATURE_CFLAGS += -D'CONFIG_MEC1308=1'
PROGRAMMER_OBJS += mec1308.o
+NEED_RAW_ACCESS += CONFIG_MEC1308
endif
ifeq ($(CONFIG_SERPROG), yes)