aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2023-03-01 21:30:45 +0100
committerThomas Heijligen <src@posteo.de>2023-03-03 17:37:23 +0000
commitc39db191d8351f1193b76c36c77225c0a18d6009 (patch)
treeaf7ed16c8cd83006d9b57266f42fffb4c12f7c21
parente1f30bbce7a603d518ecec9d7e6885719f396719 (diff)
downloadflashrom-c39db191d8351f1193b76c36c77225c0a18d6009.tar.gz
flashrom-c39db191d8351f1193b76c36c77225c0a18d6009.tar.bz2
flashrom-c39db191d8351f1193b76c36c77225c0a18d6009.zip
meson: revert to meson version 0.53.0
Debian Bullseye, current stable release, ships only with meson 0.56.2. To go back to an older meson version pass the project_version info as parameter to `sphinx-build` instead of using an environment variable. This is done by overriding the `release` variable in conf.py with `-Drelease=meson.project_version()` at the command line call. Change-Id: Iff9b8307c741a247a652cf666935c9485fa493fa Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/73361 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Alexander Goncharov <chat@joursoir.net> Reviewed-by: Anastasia Klimchuk <aklm@chromium.org>
-rw-r--r--doc/conf.py1
-rw-r--r--doc/meson.build6
-rw-r--r--meson.build2
3 files changed, 3 insertions, 6 deletions
diff --git a/doc/conf.py b/doc/conf.py
index d06f5386..79d8aaec 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -11,7 +11,6 @@ import os
project = 'flashrom'
# copyright = '2023, The flashrom authors'
author = 'The flashrom authors'
-release = os.getenv('FLASHROM_VERSION')
# -- General configuration ---------------------------------------------------
# https://www.sphinx-doc.org/en/master/usage/configuration.html#general-configuration
diff --git a/doc/meson.build b/doc/meson.build
index bdf4493f..8826e331 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -14,8 +14,7 @@ if sphinx.found()
custom_target(
'man-pages',
- command : [sphinx, '-b', 'man', '-q', '-d', '@PRIVATE_DIR@', '@CURRENT_SOURCE_DIR@', '@OUTDIR@'],
- env : {'FLASHROM_VERSION' : meson.project_version() },
+ command : [sphinx, '-b', 'man', '-q', '-d', '@PRIVATE_DIR@', '-Drelease=' + meson.project_version(),'@CURRENT_SOURCE_DIR@', '@OUTDIR@'],
build_always_stale : true, # sphinx handles rebuilds
output : man_outputs,
install : true,
@@ -26,8 +25,7 @@ if sphinx.found()
if get_option('documentation').auto() or get_option('documtation').enabled()
custom_target(
'documentation',
- command : [sphinx, '-b', 'html', '-q', '-d', '@PRIVATE_DIR@', '@CURRENT_SOURCE_DIR@', '@OUTDIR@/html'],
- env : {'FLASHROM_VERSION' : meson.project_version() },
+ command : [sphinx, '-b', 'html', '-q', '-d', '@PRIVATE_DIR@', '-Drelease=' + meson.project_version(),'@CURRENT_SOURCE_DIR@', '@OUTDIR@/html'],
build_always_stale : true, # sphinx handles rebuilds
output : 'html',
install : true,
diff --git a/meson.build b/meson.build
index caeea6e6..2ecb5faf 100644
--- a/meson.build
+++ b/meson.build
@@ -1,7 +1,7 @@
project('flashromutils', 'c',
version : run_command('util/getversion.sh', '--version', check : true).stdout().strip(),
license : 'GPL-2.0',
- meson_version : '>=0.57.0',
+ meson_version : '>=0.53.0',
default_options : [
'warning_level=2',
'c_std=c99',