aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorVictor Ding <victording@google.com>2020-11-10 23:46:04 +1100
committerEdward O'Callaghan <quasisec@chromium.org>2020-11-12 10:36:07 +0000
commit1b4de5c600f333ef32706db8d2883642b078f8bd (patch)
tree444aa0247b8235a8953829b92c84e910e8a9be67 /Makefile
parented341cf8c3bb68079651aed678c6b5019b33b268 (diff)
downloadflashrom-1b4de5c600f333ef32706db8d2883642b078f8bd.tar.gz
flashrom-1b4de5c600f333ef32706db8d2883642b078f8bd.tar.bz2
flashrom-1b4de5c600f333ef32706db8d2883642b078f8bd.zip
Disable ENE_LPC and MEC1308 on non-x86 arch
Both requires PCI port I/O and hence works only on x86. TEST=builds on Ubuntu for Raspberry Pi Signed-off-by: Victor Ding <victording@google.com> Change-Id: I69e1fbd87819b0b6370f31e9ee4c474500fb3759 Reviewed-on: https://review.coreboot.org/c/flashrom/+/47394 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Angel Pons <th3fanbus@gmail.com> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 225db9d6..04986240 100644
--- a/Makefile
+++ b/Makefile
@@ -544,6 +544,16 @@ UNSUPPORTED_FEATURES += CONFIG_SATAMV=yes
else
override CONFIG_SATAMV = no
endif
+ifeq ($(CONFIG_ENE_LPC), yes)
+UNSUPPORTED_FEATURES += CONFIG_ENE_LPC=yes
+else
+override CONFIG_ENE_LPC = no
+endif
+ifeq ($(CONFIG_MEC1308), yes)
+UNSUPPORTED_FEATURES += CONFIG_MEC1308=yes
+else
+override CONFIG_MEC1308 = no
+endif
endif
# Disable all drivers needing raw access (memory, PCI, port I/O) on