aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2021-12-14 17:25:49 +0100
committerNico Huber <nico.h@gmx.de>2021-12-22 12:35:29 +0000
commit50720a4b0b251eb1d97d4682a4db9c2c589d6019 (patch)
tree4f5229baa9c0e0a3fc42bd1384dc5f5a01c53a7d /Makefile
parent49d758698a0dd166679c48b1a2785e50e9b0cc83 (diff)
downloadflashrom-50720a4b0b251eb1d97d4682a4db9c2c589d6019.tar.gz
flashrom-50720a4b0b251eb1d97d4682a4db9c2c589d6019.tar.bz2
flashrom-50720a4b0b251eb1d97d4682a4db9c2c589d6019.zip
hwaccess physmap: move x86 msr related code into own files
Allow x86 msr related code to be compiled independent from memory mapping functionality. This enables for a better selection of needed hardware access types. Change-Id: Idc9ce9df3ea1e291ad469de59467646b294119c4 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/60111 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8de6234b..04816fae 100644
--- a/Makefile
+++ b/Makefile
@@ -806,7 +806,7 @@ PROGRAMMER_OBJS += physmap.o hwaccess.o
ifeq ($(ARCH), x86)
FEATURE_CFLAGS += -D'__FLASHROM_HAVE_OUTB__=1'
-PROGRAMMER_OBJS += hwaccess_x86_io.o
+PROGRAMMER_OBJS += hwaccess_x86_io.o hwaccess_x86_msr.o
ifeq ($(TARGET_OS), NetBSD)
PCILIBS += -l$(shell uname -p)