aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorNico Huber <nico.h@gmx.de>2021-06-26 21:47:53 +0200
committerNico Huber <nico.h@gmx.de>2021-07-12 11:00:58 +0000
commit81f5f1cd301870b845019a2c4903a2b68a598dc1 (patch)
tree01e89edb8a2b02ad725e9022f1cf63968ed117ff /Makefile
parent514e7ddc10569ebabc07d933a2096139559adebf (diff)
downloadflashrom-81f5f1cd301870b845019a2c4903a2b68a598dc1.tar.gz
flashrom-81f5f1cd301870b845019a2c4903a2b68a598dc1.tar.bz2
flashrom-81f5f1cd301870b845019a2c4903a2b68a598dc1.zip
Revert "Mark ENE_LPC and MEC1308 as NEED_LIBPCI"
This reverts commit cf1e8f7b904ddf639b29b2e1bb0ad681c1aad76d. It's an indirect, spurious dependency. Why clutter the build system with it? Instead, the functions these programmers actually depend on should be factored into a compilation unit that doesn't need PCI. No matter this change, compilation with `CONFIG_INTERNAL=no` is broken because of these programmers right now. Change-Id: I134eb7d74b44f92dfdea3c764f39bc3673739fa0 Signed-off-by: Nico Huber <nico.h@gmx.de> Reviewed-on: https://review.coreboot.org/c/flashrom/+/55869 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Angel Pons <th3fanbus@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 4d68cdb3..2ed193d0 100644
--- a/Makefile
+++ b/Makefile
@@ -809,10 +809,8 @@ override CONFIG_SATASII = no
override CONFIG_ATAHPT = no
override CONFIG_ATAVIA = no
override CONFIG_ATAPROMISE = no
-override CONFIG_ENE_LPC = no
override CONFIG_IT8212 = no
override CONFIG_DRKAISER = no
-override CONFIG_MEC1308 = no
override CONFIG_NICREALTEK = no
override CONFIG_NICNATSEMI = no
override CONFIG_NICINTEL = no
@@ -892,14 +890,12 @@ ifeq ($(CONFIG_ENE_LPC), yes)
FEATURE_CFLAGS += -D'CONFIG_ENE_LPC=1'
PROGRAMMER_OBJS += ene_lpc.o
NEED_RAW_ACCESS += CONFIG_ENE_LPC
-NEED_LIBPCI += CONFIG_ENE_LPC
endif
ifeq ($(CONFIG_MEC1308), yes)
FEATURE_CFLAGS += -D'CONFIG_MEC1308=1'
PROGRAMMER_OBJS += mec1308.o
NEED_RAW_ACCESS += CONFIG_MEC1308
-NEED_LIBPCI += CONFIG_MEC1308
endif
ifeq ($(CONFIG_SERPROG), yes)