aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAngel Pons <th3fanbus@gmail.com>2021-04-17 17:47:54 +0200
committerAngel Pons <th3fanbus@gmail.com>2021-04-21 14:48:28 +0000
commit87718aadb42b499ad7473528e6bb4cd522f3237d (patch)
tree660124c21bbbffade8ad881a61c79af39655e65b /Makefile
parentf0ab83f5f49db987c5ccaa4a534e76bad78fbdbe (diff)
downloadflashrom-87718aadb42b499ad7473528e6bb4cd522f3237d.tar.gz
flashrom-87718aadb42b499ad7473528e6bb4cd522f3237d.tar.bz2
flashrom-87718aadb42b499ad7473528e6bb4cd522f3237d.zip
Makefile: Disable libusb-dependent Raiden on DOS
DOS (DJGPP 6.1.0) has no USB support. Change-Id: I36ee1edfb0e5b8d4e2b099c0f7f8aac64ed7884f Signed-off-by: Angel Pons <th3fanbus@gmail.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/52474 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 0cfff55d..d496a9a3 100644
--- a/Makefile
+++ b/Makefile
@@ -202,6 +202,11 @@ UNSUPPORTED_FEATURES += CONFIG_CH341A_SPI=yes
else
override CONFIG_CH341A_SPI = no
endif
+ifeq ($(CONFIG_RAIDEN_DEBUG_SPI), yes)
+UNSUPPORTED_FEATURES += CONFIG_RAIDEN_DEBUG_SPI=yes
+else
+override CONFIG_RAIDEN_DEBUG_SPI = no
+endif
ifeq ($(CONFIG_STLINKV3_SPI), yes)
UNSUPPORTED_FEATURES += CONFIG_STLINKV3_SPI=yes
else