aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorLuc Verhaegen <libv@skynet.be>2007-04-04 22:45:58 +0000
committerStefan Reinauer <stefan.reinauer@coreboot.org>2007-04-04 22:45:58 +0000
commit8e3a600123110d47076926cb8ee7c68195658f20 (patch)
treed2865da3322423bfafd95ef73853e29bb1833377 /Makefile
parentaf2b52dc5f48f245d9b6097a03d4b1f52938a891 (diff)
downloadflashrom-8e3a600123110d47076926cb8ee7c68195658f20.tar.gz
flashrom-8e3a600123110d47076926cb8ee7c68195658f20.tar.bz2
flashrom-8e3a600123110d47076926cb8ee7c68195658f20.zip
Split flash_enable.c into chipset_enable.c and board_enable.c
This splits up the ROM Write enable code into chipset specific and board specific parts. This of course means that a lot of code is plainly moved about. * Allows for linuxbios name matching and pci-subsystem id matching. The latter uses a double set to properly distuinguish boards despite of some known vendors being lax about it. * Fixes GPIO15 being raised on every VT8235 southbridge, regardless of what that line actually controls; rom on EPIA-M, backlight on mitac 8999 laptop. * Adds flashrom support for Asus A7V400-MX (KM400 + VT8235) * Island aruma was renamed agami aruma, the board specific code now got adjusted. A set of pci-ids was retrieved from source code. Corresponding to flashrom svn r99 and coreboot v2 svn r2581. Signed-off-by: Luc Verhaegen <libv@skynet.be> Acked-by: Stefan Reinauer <stepan@coresystems.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index a6b389f2..bb460c59 100644
--- a/Makefile
+++ b/Makefile
@@ -20,10 +20,11 @@ LDFLAGS = -lpci -lz -static
STRIP_ARGS = -s
endif
-OBJS = flash_enable.o udelay.o jedec.o sst28sf040.o am29f040b.o mx29f002.o \
- sst39sf020.o m29f400bt.o w49f002u.o 82802ab.o msys_doc.o pm49fl004.o \
- sst49lf040.o sst49lfxxxc.o sst_fwhub.o layout.o lbtable.o \
- flashchips.o flash_rom.o sharplhf00l04.o
+OBJS = chipset_enable.o board_enable.o udelay.o jedec.o sst28sf040.o \
+ am29f040b.o mx29f002.o sst39sf020.o m29f400bt.o w49f002u.o \
+ 82802ab.o msys_doc.o pm49fl004.o sst49lf040.o sst49lfxxxc.o \
+ sst_fwhub.o layout.o lbtable.o flashchips.o flash_rom.o \
+ sharplhf00l04.o
all: pciutils dep $(PROGRAM)