aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorCarl-Daniel Hailfinger <c-d.hailfinger.devel.2006@gmx.net>2010-12-05 16:33:59 +0000
committerCarl-Daniel Hailfinger <c-d.hailfinger.devel.2006@gmx.net>2010-12-05 16:33:59 +0000
commit9188240a14d77a1ceb5ab07e61a8d3c602e7995d (patch)
tree39b925cc2b32ac0ca975cbfe24d9cdf8a3c175c8 /Makefile
parentdce73ae62212c7e22d28ee0d9e48aaccd1cab46a (diff)
downloadflashrom-9188240a14d77a1ceb5ab07e61a8d3c602e7995d.tar.gz
flashrom-9188240a14d77a1ceb5ab07e61a8d3c602e7995d.tar.bz2
flashrom-9188240a14d77a1ceb5ab07e61a8d3c602e7995d.zip
Add support for Winbond W39V040FB and W39V040FC
Print lock status for all supported Winbond W39* chips: W39V040A, W39V040B, W39V040C, W39V040FA, W39V040FB, W39V040FC, W39V080A, W39V080FA, W39V080FA (dual mode). Fill in correct probe timing for Winbond W39V040C and W39V080FA. Please note that the W39V040B/W39V040FB pair has identical IDs, identical read/write/erase, but locking differs. Same applies to W39V040C/W39V040FC. This causes double detection on chipsets which support LPC and FWH, making flashing more difficult because the user has to select the correct chip. This is called the evil twin problem. A better evil twin handling (patch available) will resolve that problem. Corresponding to flashrom svn r1245. Signed-off-by: Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006@gmx.net> Acked-by: Michael Karcher <flashrom@mkarcher.dialup.fu-berlin.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 0f20b8a6..370318cc 100644
--- a/Makefile
+++ b/Makefile
@@ -82,7 +82,7 @@ override CONFIG_FT2232_SPI = no
endif
endif
-CHIP_OBJS = jedec.o stm50flw0x0x.o w39v040c.o w39v080fa.o w29ee011.o \
+CHIP_OBJS = jedec.o stm50flw0x0x.o w39.o w29ee011.o \
sst28sf040.o m29f400bt.o 82802ab.o pm49fl00x.o \
sst49lfxxxc.o sst_fwhub.o flashchips.o spi.o spi25.o sharplhf00l04.o