aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.de>2021-10-12 15:54:06 +0200
committerNico Huber <nico.h@gmx.de>2021-10-15 14:35:29 +0000
commitba1c5eb12591c306604929b94b9046a37170c5ff (patch)
tree51c3425081abcb4d44769b2227a4e966d39a9560 /Makefile
parentcf542aa1ce3caabe5184fde77a39bbd3cca763ef (diff)
downloadflashrom-ba1c5eb12591c306604929b94b9046a37170c5ff.tar.gz
flashrom-ba1c5eb12591c306604929b94b9046a37170c5ff.tar.bz2
flashrom-ba1c5eb12591c306604929b94b9046a37170c5ff.zip
Makefile: copy determination test for the endian to Makefile.d
Copy the test code for endian detection in an extra directory to split it from the main flashrom code. Change-Id: I0c2420fd60d7d6a23c94c9962b06bfd7f3c86ad8 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.de> Reviewed-on: https://review.coreboot.org/c/flashrom/+/58270 Reviewed-by: Nico Huber <nico.h@gmx.de> Tested-by: build bot (Jenkins) <no-reply@coreboot.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 1e96e8a9..cea5c69b 100644
--- a/Makefile
+++ b/Makefile
@@ -164,8 +164,7 @@ endif
# the lines below use CC itself.
override TARGET_OS := $(call c_macro_test, Makefile.d/os_test.h)
override ARCH := $(call c_macro_test, Makefile.d/arch_test.h)
-override ENDIAN := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E endiantest.c 2>/dev/null \
- | tail -1))
+override ENDIAN := $(call c_macro_test, Makefile.d/endian_test.h)
ifeq ($(TARGET_OS), $(filter $(TARGET_OS), FreeBSD OpenBSD DragonFlyBSD))
override CPPFLAGS += -I/usr/local/include
@@ -869,6 +868,8 @@ compiler: featuresavailable
@if [ $(ARCH) = unknown ]; then echo Aborting.; exit 1; fi
@echo Target OS is $(TARGET_OS)
@if [ $(TARGET_OS) = unknown ]; then echo Aborting.; exit 1; fi
+ @echo Target endian is $(ENDIAN)
+ @if [ $(ENDIAN) = unknown ]; then echo Aborting.; exit 1; fi
ifeq ($(TARGET_OS), libpayload)
@$(CC) --version 2>&1 | grep -q coreboot || \
( echo "Warning: It seems you are not using coreboot's reference compiler."; \