aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorCarl-Daniel Hailfinger <c-d.hailfinger.devel.2006@gmx.net>2010-01-19 11:15:48 +0000
committerCarl-Daniel Hailfinger <c-d.hailfinger.devel.2006@gmx.net>2010-01-19 11:15:48 +0000
commitd38fac8c261e4d7e3857453dfb612b9094f63e95 (patch)
treef0c9704289953cb4c119ec42dfdac2150c322111 /Makefile
parent415afcffc17492762d766939953ec2245b8582b0 (diff)
downloadflashrom-d38fac8c261e4d7e3857453dfb612b9094f63e95.tar.gz
flashrom-d38fac8c261e4d7e3857453dfb612b9094f63e95.tar.bz2
flashrom-d38fac8c261e4d7e3857453dfb612b9094f63e95.zip
Dediprog SF100 support
Reverse engineered from USB logs. I never touched that programmer nor did I ever see the associated software. Disabled by default until it is complete. The driver needs to be hooked up to the SPI core before it will do anything besides init and diagnostics. I successfully reverse engineered all commands, but some are still somewhat magic. Logs from "flashrom -p dediprog -V" are appreciated. Probe and read should work, erase/write is expected to explode. The programmer will set voltage to 0 on exit. Thanks a lot to Stefan Reinauer and Patrick Georgi for providing USB logs and for testing the result. Corresponding to flashrom svn r870. Signed-off-by: Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006@gmx.net> Acked-by: Stefan Reinauer <stepan@coresystems.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 501f65a1..6f6ee831 100644
--- a/Makefile
+++ b/Makefile
@@ -96,6 +96,9 @@ CONFIG_DRKAISER ?= yes
# Always enable Bus Pirate SPI for now.
CONFIG_BUSPIRATESPI ?= yes
+# Disable Dediprog SF100 until support is complete and tested.
+CONFIG_DEDIPROG ?= no
+
# Disable wiki printing by default. It is only useful if you have wiki access.
CONFIG_PRINT_WIKI ?= no
@@ -160,6 +163,12 @@ FEATURE_CFLAGS += -D'BUSPIRATE_SPI_SUPPORT=1'
PROGRAMMER_OBJS += buspirate_spi.o
endif
+ifeq ($(CONFIG_DEDIPROG), yes)
+FEATURE_CFLAGS += -D'DEDIPROG_SUPPORT=1'
+FEATURE_LIBS += -lusb
+PROGRAMMER_OBJS += dediprog.o
+endif
+
# Ugly, but there's no elif/elseif.
ifeq ($(CONFIG_SERPROG), yes)
LIB_OBJS += serial.o