aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorVictor Ding <victording@google.com>2021-07-21 17:37:12 +1000
committerNico Huber <nico.h@gmx.de>2021-09-22 13:22:21 +0000
commite3f55a13ba256bf643aa47084db16a98c3fe60e6 (patch)
treea39e1c8324c10fe861243331391607f034640aad /Makefile
parentbbe9a77343952e50015468dfc67f141f5ed4a4a3 (diff)
downloadflashrom-e3f55a13ba256bf643aa47084db16a98c3fe60e6.tar.gz
flashrom-e3f55a13ba256bf643aa47084db16a98c3fe60e6.tar.bz2
flashrom-e3f55a13ba256bf643aa47084db16a98c3fe60e6.zip
ene_lpc: remove ENE LPC programmer
Best efforts were made to upstream older Chromebook support for good intentions for folks interested. However, we no longer have the hardware available to test and maintain the code as the hardware is now end of life. Therefore the code state has sadly fallen into a unknown state. BUG=none BRANCH=none TEST=builds and ninja test passes Signed-off-by: Victor Ding <victording@google.com> Change-Id: I3f40db22c42c04ce029c4defd837e05ebb550c9b Reviewed-on: https://review.coreboot.org/c/flashrom/+/56475 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 3 insertions, 14 deletions
diff --git a/Makefile b/Makefile
index 27f66a99..2182121b 100644
--- a/Makefile
+++ b/Makefile
@@ -217,8 +217,6 @@ LIBS += -lgetopt
$(call mark_unsupported,$(DEPENDS_ON_SERIAL))
# Libraries not available for DOS
$(call mark_unsupported,$(DEPENDS_ON_LIBUSB1) $(DEPENDS_ON_LIBFTDI) $(DEPENDS_ON_LIBJAYLINK))
-# Odd ones (FIXME: why are they unsupported?)
-$(call mark_unsupported,CONFIG_ENE_LPC CONFIG_MEC1308)
endif
# FIXME: Should we check for Cygwin/MSVC as well?
@@ -233,7 +231,7 @@ FLASHROM_CFLAGS += -D__USE_MINGW_ANSI_STDIO=1
# For now we disable all PCI-based programmers on Windows/MinGW (no libpci).
$(call mark_unsupported,$(DEPENDS_ON_LIBPCI))
# And programmers that need raw access.
-$(call mark_unsupported,CONFIG_ENE_LPC CONFIG_MEC1308 CONFIG_RAYER_SPI)
+$(call mark_unsupported,CONFIG_MEC1308 CONFIG_RAYER_SPI)
else # No MinGW
@@ -256,7 +254,7 @@ $(call mark_unsupported,CONFIG_BUSPIRATE_SPI CONFIG_SERPROG CONFIG_PONY_SPI)
# Dediprog, Developerbox, USB-Blaster, PICkit2, CH341A and FT2232 are not supported with libpayload (missing libusb support).
$(call mark_unsupported,$(DEPENDS_ON_LIBUSB1) $(DEPENDS_ON_LIBFTDI) $(DEPENDS_ON_LIBJAYLINK))
# Odd ones. (FIXME: why?)
-$(call mark_unsupported,CONFIG_ENE_LPC CONFIG_MEC1308)
+$(call mark_unsupported,CONFIG_MEC1308)
endif
# Android is handled internally as separate OS, but it supports about the same drivers as Linux.
@@ -297,7 +295,7 @@ endif
ifneq ($(ARCH), x86)
$(call mark_unsupported,CONFIG_NIC3COM CONFIG_NICREALTEK CONFIG_NICNATSEMI)
$(call mark_unsupported,CONFIG_RAYER_SPI CONFIG_ATAHPT CONFIG_ATAPROMISE)
-$(call mark_unsupported,CONFIG_SATAMV CONFIG_ENE_LPC CONFIG_MEC1308)
+$(call mark_unsupported,CONFIG_SATAMV CONFIG_MEC1308)
endif
# Additionally disable all drivers needing raw access (memory, PCI, port I/O)
@@ -382,9 +380,6 @@ CONFIG_ATAVIA ?= yes
# Promise ATA controller support.
CONFIG_ATAPROMISE ?= no
-# ENE LPC interface keyboard controller
-CONFIG_ENE_LPC ?= yes
-
# Always enable FT2232 SPI dongles for now.
CONFIG_FT2232_SPI ?= yes
@@ -534,12 +529,6 @@ else
endif
endif
-ifeq ($(CONFIG_ENE_LPC), yes)
-FEATURE_CFLAGS += -D'CONFIG_ENE_LPC=1'
-PROGRAMMER_OBJS += ene_lpc.o
-NEED_RAW_ACCESS += CONFIG_ENE_LPC
-endif
-
ifeq ($(CONFIG_MEC1308), yes)
FEATURE_CFLAGS += -D'CONFIG_MEC1308=1'
PROGRAMMER_OBJS += mec1308.o