aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorUwe Hermann <uwe@hermann-uwe.de>2009-05-17 22:57:34 +0000
committerUwe Hermann <uwe@hermann-uwe.de>2009-05-17 22:57:34 +0000
commiteaefb48ee5137db9c508acbb8b5a59c6f8fa1a94 (patch)
tree07041ee05a931c6a5fda882d9ac44632e94663ea /Makefile
parent525339c32b6ec965117442bcc188b3261fb006ff (diff)
downloadflashrom-eaefb48ee5137db9c508acbb8b5a59c6f8fa1a94.tar.gz
flashrom-eaefb48ee5137db9c508acbb8b5a59c6f8fa1a94.tar.bz2
flashrom-eaefb48ee5137db9c508acbb8b5a59c6f8fa1a94.zip
Various smaller flashrom improvements
- Document new 'satasii' programmer in -L output and manpage. - Drop PCI_IO_BASE_ADDRESS, pci.h has such #defines already. - Beautify flashrom output and make it more consistent. - Same for the 'make' output (reordered some $CC parameters). Build-tested on i386, shouldn't break any builds, I think. - Some variable renaming and other cosmetic fixes. Corresponding to flashrom svn r529. Signed-off-by: Uwe Hermann <uwe@hermann-uwe.de> Acked-by: Uwe Hermann <uwe@hermann-uwe.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ede24815..deab9995 100644
--- a/Makefile
+++ b/Makefile
@@ -46,7 +46,7 @@ $(PROGRAM): $(OBJS)
$(CC) $(LDFLAGS) -o $(PROGRAM) $(OBJS) $(LIBS)
flashrom.o: flashrom.c
- $(CC) -c $(CFLAGS) $(SVNDEF) $(CPPFLAGS) $< -o $@
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $< $(SVNDEF)
clean:
rm -f $(PROGRAM) *.o