aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJean THOMAS <virgule@jeanthomas.me>2022-10-11 17:54:30 +0200
committerFelix Singer <felixsinger@posteo.net>2022-10-15 18:17:38 +0000
commit001c87d9014b5b2dbb8adc9f64ab7023359a38b4 (patch)
tree3f9862342bc76f0c5ef0c5a916bb58c221224376 /meson.build
parent5d3b95bbaccb2453aeeaf6092e3a9f295c829271 (diff)
downloadflashrom-001c87d9014b5b2dbb8adc9f64ab7023359a38b4.tar.gz
flashrom-001c87d9014b5b2dbb8adc9f64ab7023359a38b4.tar.bz2
flashrom-001c87d9014b5b2dbb8adc9f64ab7023359a38b4.zip
dirtyjtag: Add DirtyJTAG programmer
Add a new programmer driver for the DirtyJTAG project (a USB-JTAG firmware for STM32 MCUs). Successfully tested with DirtyJTAG 1.4 running on an Olimex STM32-H103 development board and a SST25VF020B SPI flash chip. Change-Id: Ic43e9a014ed7d04e429e73b30c9dcfdde1a78913 Signed-off-by: Jean THOMAS <virgule@jeanthomas.me> Reviewed-on: https://review.coreboot.org/c/flashrom/+/67878 Reviewed-by: Felix Singer <felixsinger@posteo.net> Reviewed-by: Angel Pons <th3fanbus@gmail.com> Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 050631d4..3a6cc411 100644
--- a/meson.build
+++ b/meson.build
@@ -202,6 +202,12 @@ programmer = {
'srcs' : files('digilent_spi.c'),
'flags' : [ '-DCONFIG_DIGILENT_SPI=1' ],
},
+ 'dirtyjtag_spi' : {
+ 'deps' : [ libusb1 ],
+ 'groups' : [ group_usb, group_external ],
+ 'srcs' : files('dirtyjtag_spi.c'),
+ 'flags' : [ '-DCONFIG_DIRTYJTAG_SPI=1' ],
+ },
'drkaiser' : {
'systems' : systems_hwaccess,
'deps' : [ libpci ],