aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2022-01-20 16:45:14 +0100
committerNico Huber <nico.h@gmx.de>2022-03-14 11:30:54 +0000
commit0f51f62c6265af5977fec7425596b65a3926c42b (patch)
treef83d354734454f4fd7ebfc6717ec3087b5598b33 /meson.build
parent60c3b61d09b6d0522af4242a351b0f52f18dd036 (diff)
downloadflashrom-0f51f62c6265af5977fec7425596b65a3926c42b.tar.gz
flashrom-0f51f62c6265af5977fec7425596b65a3926c42b.tar.bz2
flashrom-0f51f62c6265af5977fec7425596b65a3926c42b.zip
hwaccess_x86_io: clean header concept
Move all function implementations into the .c file TEST: `[g]make [WARNERROR=no]` on Linux, FreeBSD, NetBSD, OpenBSD, DragonflyBSD, OpenIndiana, Debian-GNU/Hurd Change-Id: I1400704e9ac5fed00c096796536108d5bfb875e3 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/61276 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 0 insertions, 18 deletions
diff --git a/meson.build b/meson.build
index cc393a7c..b7fc25fb 100644
--- a/meson.build
+++ b/meson.build
@@ -42,24 +42,6 @@ else
add_project_arguments('-DIS_WINDOWS=0', language : 'c')
endif
-if host_machine.system() in ['linux', 'darwin', 'netbsd', 'openbsd']
- add_project_arguments('-DUSE_IOPL=1', language : 'c')
-else
- add_project_arguments('-DUSE_IOPL=0', language : 'c')
-endif
-
-if host_machine.system() in ['freebsd', 'dragonfly']
- add_project_arguments('-DUSE_DEV_IO=1', language : 'c')
-else
- add_project_arguments('-DUSE_DEV_IO=0', language : 'c')
-endif
-
-if host_machine.system() in ['gnu']
- add_project_arguments('-DUSE_IOPERM=1', language : 'c')
-else
- add_project_arguments('-DUSE_IOPERM=0', language : 'c')
-endif
-
# get defaults from configure
config_atahpt = get_option('config_atahpt')
config_atapromise = get_option('config_atapromise')