aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJacob Garber <jgarber1@ualberta.ca>2019-07-25 19:12:31 -0600
committerNico Huber <nico.h@gmx.de>2019-10-04 14:35:20 +0000
commit4a84ec273a487c27f91bd3df70cbdf8894af70e1 (patch)
treefaee09346d0a195ac778befa68a87c5f669cfe22 /meson.build
parentde77ad4678cb33ca0b58edf89fab8113eb304bcd (diff)
downloadflashrom-4a84ec273a487c27f91bd3df70cbdf8894af70e1.tar.gz
flashrom-4a84ec273a487c27f91bd3df70cbdf8894af70e1.tar.bz2
flashrom-4a84ec273a487c27f91bd3df70cbdf8894af70e1.zip
tree: Enable -Wwrite-strings
When compiling, this warning gives string literals the type const char[] to help catch accidental modification (which is undefined behaviour). There currently aren't any instances of this in flashrom, so let's enable this warning to keep it that way. This requires adding const qualifiers to the declarations of several variables that work with string literals. Change-Id: I62d9bc194938a0c9a0e4cdff7ced8ea2e14cc1bc Signed-off-by: Jacob Garber <jgarber1@ualberta.ca> Reviewed-on: https://review.coreboot.org/c/flashrom/+/34577 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: David Hendricks <david.hendricks@gmail.com> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e1b6c166..d778d716 100644
--- a/meson.build
+++ b/meson.build
@@ -11,8 +11,9 @@ lt_revision = '0'
lt_age = '0'
lt_version = '@0@.@1@.@2@'.format(lt_current, lt_age, lt_revision)
-# hide some warnings
+# hide/enable some warnings
warning_flags = [
+ '-Wwrite-strings',
'-Wno-unused-parameter',
'-Wno-sign-compare',
'-Wno-address-of-packed-member',