aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNico Huber <nico.huber@secunet.com>2022-09-05 17:42:57 +0200
committerAnastasia Klimchuk <aklm@chromium.org>2022-09-08 06:27:10 +0000
commit845b10694d68c071dab1526ba536e3c87961903a (patch)
tree0378c6f46fa33f2205a99ed22a181c81669fc04c /meson.build
parent6f5c8fdfc32e8b4cdcabb8f40e1a4a5452a60282 (diff)
downloadflashrom-845b10694d68c071dab1526ba536e3c87961903a.tar.gz
flashrom-845b10694d68c071dab1526ba536e3c87961903a.tar.bz2
flashrom-845b10694d68c071dab1526ba536e3c87961903a.zip
Revert "cmocka: Drop as meson subproject"
This reverts commit 99eca0899b931b21b7c44ed1753c5f01b35798af. The environment provided by our Jenkins builder doesn't have cmocka. It's not exactly known why it worked as a subproject. However, if it allows us to enforce tests in the CI, we should revert now and drop the subproject again once the environment is updated. Change-Id: Iafdab92eb8ab96d02fb2c29524d785bdc7a54034 Signed-off-by: Nico Huber <nico.huber@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/67345 Reviewed-by: Felix Singer <felixsinger@posteo.net> Reviewed-by: Thomas Heijligen <src@posteo.de> Reviewed-by: Angel Pons <th3fanbus@gmail.com> Reviewed-by: Anastasia Klimchuk <aklm@chromium.org> Tested-by: build bot (Jenkins) <no-reply@coreboot.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 3a60f92d..366ce18a 100644
--- a/meson.build
+++ b/meson.build
@@ -500,7 +500,11 @@ endif
# `.allowed()` gets introduced in 0.59.0
if get_option('tests').auto() or get_option('tests').enabled()
# unit-test framework
- cmocka = dependency('cmocka', required : get_option('tests'))
+ cmocka_dep = dependency(
+ 'cmocka',
+ fallback: ['cmocka', 'cmocka_dep'],
+ required : get_option('tests')
+ )
flashrom_test_dep = declare_dependency(
include_directories : include_dir,
@@ -519,7 +523,7 @@ if get_option('tests').auto() or get_option('tests').enabled()
],
)
- if cmocka.found()
+ if cmocka_dep.found()
subdir('tests')
endif
endif