aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.de>2021-10-12 17:38:01 +0200
committerNico Huber <nico.h@gmx.de>2021-10-15 14:36:00 +0000
commitc9d947576bad1854fe7899e9bccc22ce0e649554 (patch)
treefddc509402faf876d2f25d8eba2ae740179b446f /meson.build
parent494180096c1125485549c9cc83c8291a3cb3d9b8 (diff)
downloadflashrom-c9d947576bad1854fe7899e9bccc22ce0e649554.tar.gz
flashrom-c9d947576bad1854fe7899e9bccc22ce0e649554.tar.bz2
flashrom-c9d947576bad1854fe7899e9bccc22ce0e649554.zip
buildsystem: handle the IS_WINDOWS macro
On Windows target systems set the IS_WINDOWS=1 macro by the buildsystem. Change-Id: I334708f2dec08ec9ca6ad4161fbd7fe22ac023a6 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.de> Reviewed-on: https://review.coreboot.org/c/flashrom/+/58277 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 02dedfcf..a971a6a6 100644
--- a/meson.build
+++ b/meson.build
@@ -36,6 +36,12 @@ if host_machine.endian() == 'big'
add_project_arguments('-D__FLASHROM_BIG_ENDIAN__=1', language : 'c')
endif
+if host_machine.system() in ['cygwin', 'windows']
+ add_project_arguments('-DIS_WINDOWS=1', language : 'c')
+else
+ add_project_arguments('-DIS_WINDOWS=0', language : 'c')
+endif
+
# get defaults from configure
config_atahpt = get_option('config_atahpt')
config_atapromise = get_option('config_atapromise')