aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAnastasia Klimchuk <aklm@chromium.org>2021-10-25 13:20:26 +1100
committerAnastasia Klimchuk <aklm@chromium.org>2022-04-29 04:30:55 +0000
commitd431358621001a75497ebeae32277fcb5ecfc4da (patch)
treee15f45986758eea293e3803e88e0698765769b2f /meson.build
parentc4784f1a9a491eab118bbec81808e2de1dec187f (diff)
downloadflashrom-d431358621001a75497ebeae32277fcb5ecfc4da.tar.gz
flashrom-d431358621001a75497ebeae32277fcb5ecfc4da.tar.bz2
flashrom-d431358621001a75497ebeae32277fcb5ecfc4da.zip
Add -W options from Makefile into meson warning_flags
Makefile options were more restrictive and produced more warnings. This patch adds missing warning options into meson build. Makefile also has -Wall and -Wextra specified explicitly, however this is covered by warning_level=2 which is already set in meson.build. warning_level info: https://github.com/mesonbuild/meson/issues/3275 There are few warning options that are present in meson, but not in Makefile. These are left as is. TEST=ninja test shows no warnings and tests pass Change-Id: Id401bfd642dc3c13d85bd9a2dba56ada38714c25 Signed-off-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/58561 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Thomas Heijligen <src@posteo.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 32e31df3..e9eb4d25 100644
--- a/meson.build
+++ b/meson.build
@@ -13,6 +13,8 @@ lt_version = '@0@.@1@.@2@'.format(lt_current, lt_age, lt_revision)
# hide/enable some warnings
warning_flags = [
+ '-Wshadow',
+ '-Wmissing-prototypes',
'-Wwrite-strings',
'-Wno-unused-parameter',
'-Wno-address-of-packed-member',