aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2022-06-30 10:29:44 +0200
committerAnastasia Klimchuk <aklm@chromium.org>2022-07-17 22:43:56 +0000
commitdf0bbf07dec6fcfe8f03f2a0774630a9135c2711 (patch)
treed54a4695d994a5ebf245b92f226f811f59d58d99 /meson.build
parent494bedae23c547e0a3e8f86a5a69cf4b05bd1586 (diff)
downloadflashrom-df0bbf07dec6fcfe8f03f2a0774630a9135c2711.tar.gz
flashrom-df0bbf07dec6fcfe8f03f2a0774630a9135c2711.tar.bz2
flashrom-df0bbf07dec6fcfe8f03f2a0774630a9135c2711.zip
Rename lspcon_i2c_spi to parade_lspcon
The chip targeted by the `lspcon_i2c_spi` programmer is a Parade PS175. Rename the programmer to match the chips vendor / family instead of the generic LSPCON protocol. Remove the `_i2c_spi` ending in preparation to become an opaque master. The chip is visible on an Acer Chromebox CXI4. https://www.paradetech.com/products/ps175/ https://www.acer.com/ac/en/US/content/series/acerchromeboxcxi4 TEST: `make CONFIG_PARADE_LSPCON=yes` and `meson build -Dconfig_parade_lspcon=true` produces flashrom binaries with the parade_lspcon programmer included. Change-Id: I9148be6d9162c1722ff739929ca5e181b628dd57 Signed-off-by: Thomas Heijligen <src@posteo.de> Reviewed-on: https://review.coreboot.org/c/flashrom/+/65547 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Felix Singer <felixsinger@posteo.net> Reviewed-by: Angel Pons <th3fanbus@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 914b8896..83e175ce 100644
--- a/meson.build
+++ b/meson.build
@@ -71,7 +71,7 @@ config_satasii = get_option('config_satasii')
config_serprog = get_option('config_serprog')
config_usbblaster_spi = get_option('config_usbblaster_spi')
config_stlinkv3_spi = get_option('config_stlinkv3_spi')
-config_lspcon_i2c_spi = get_option('config_lspcon_i2c_spi')
+config_parade_lspcon = get_option('config_parade_lspcon')
config_mediatek_i2c_spi = get_option('config_mediatek_i2c_spi')
config_realtek_mst_i2c_spi = get_option('config_realtek_mst_i2c_spi')
config_print_wiki= get_option('print_wiki')
@@ -359,9 +359,9 @@ if config_stlinkv3_spi
srcs += files('stlinkv3_spi.c')
cargs += '-DCONFIG_STLINKV3_SPI=1'
endif
-if config_lspcon_i2c_spi
- srcs += files('lspcon_i2c_spi.c')
- cargs += '-DCONFIG_LSPCON_I2C_SPI=1'
+if config_parade_lspcon
+ srcs += files('parade_lspcon.c')
+ cargs += '-DCONFIG_PARADE_LSPCON=1'
endif
if config_mediatek_i2c_spi
srcs += files('mediatek_i2c_spi.c')