aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNeill Corlett <corlett@google.com>2022-01-20 21:50:30 -0500
committerEdward O'Callaghan <quasisec@chromium.org>2022-02-01 22:22:03 +0000
commite98b2d11846fe0f7a64e8739ec5d8e901a54dfc8 (patch)
treed99b00509184ecce7c7ff5d57ff8210d0cf71c1f /meson.build
parent55aa056c7404e0912ed2e56b682512df7a0cca77 (diff)
downloadflashrom-e98b2d11846fe0f7a64e8739ec5d8e901a54dfc8.tar.gz
flashrom-e98b2d11846fe0f7a64e8739ec5d8e901a54dfc8.tar.bz2
flashrom-e98b2d11846fe0f7a64e8739ec5d8e901a54dfc8.zip
Add mediatek_i2c_spi interface
Add a spi_master interface supporting MediaTek MST9U ISP mode. Autodetect the bus type via I2C_FUNC_I2C, and use the appropriate read/write commands, in case the MST9U is attached to smbus. TEST=Successfully programmed SPI on test hardware. Change-Id: I24adb14e7b4f7160e1c3ff941774064d5a81e820 Signed-off-by: Neill Corlett <corlett@google.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/61288 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index cb34e54c..cd9f9fb9 100644
--- a/meson.build
+++ b/meson.build
@@ -96,6 +96,7 @@ config_serprog = get_option('config_serprog')
config_usbblaster_spi = get_option('config_usbblaster_spi')
config_stlinkv3_spi = get_option('config_stlinkv3_spi')
config_lspcon_i2c_spi = get_option('config_lspcon_i2c_spi')
+config_mediatek_i2c_spi = get_option('config_mediatek_i2c_spi')
config_realtek_mst_i2c_spi = get_option('config_realtek_mst_i2c_spi')
config_print_wiki= get_option('print_wiki')
config_default_programmer_name = get_option('default_programmer_name')
@@ -345,6 +346,10 @@ if config_lspcon_i2c_spi
srcs += 'lspcon_i2c_spi.c'
cargs += '-DCONFIG_LSPCON_I2C_SPI=1'
endif
+if config_mediatek_i2c_spi
+ srcs += 'mediatek_i2c_spi.c'
+ cargs += '-DCONFIG_MEDIATEK_I2C_SPI=1'
+endif
if config_realtek_mst_i2c_spi
srcs += 'realtek_mst_i2c_spi.c'
cargs += '-DCONFIG_REALTEK_MST_I2C_SPI=1'