aboutsummaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorAnastasia Klimchuk <aklm@chromium.org>2021-06-30 09:26:59 +1000
committerEdward O'Callaghan <quasisec@chromium.org>2021-07-19 03:23:04 +0000
commit02bc0b2c53d1c20d676ac11bbfa84f42d2fb070c (patch)
tree0848b8d031d5973a367b467b0cb0977afb47546b /tests/meson.build
parent942004398632e8e71e2b29ee476233be569615ba (diff)
downloadflashrom-02bc0b2c53d1c20d676ac11bbfa84f42d2fb070c.tar.gz
flashrom-02bc0b2c53d1c20d676ac11bbfa84f42d2fb070c.tar.bz2
flashrom-02bc0b2c53d1c20d676ac11bbfa84f42d2fb070c.zip
dediprog: Init-shutdown test for dediprog
This patch adds mocks for libusb functions. To avoid dependency on libusb.h, libusb symbols for context and device handle are redefined. Real libusb functions are never called in tests anyway, cmocka wraps work with this without complaints. BUG=b:181803212 TEST=builds and ninja test Change-Id: I38508dfb6d7c24d42522f22fcae0c5e410c5f7ea Signed-off-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/55934 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 852fd4c1..a18bc455 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -39,6 +39,13 @@ mocks = [
'-Wl,--wrap=test_inw',
'-Wl,--wrap=test_outl',
'-Wl,--wrap=test_inl',
+ '-Wl,--wrap=usb_dev_get_by_vid_pid_number',
+ '-Wl,--wrap=libusb_set_configuration',
+ '-Wl,--wrap=libusb_claim_interface',
+ '-Wl,--wrap=libusb_control_transfer',
+ '-Wl,--wrap=libusb_release_interface',
+ '-Wl,--wrap=libusb_close',
+ '-Wl,--wrap=libusb_exit',
'-Wl,--gc-sections',
]