aboutsummaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorEdward O'Callaghan <quasisec@google.com>2020-05-22 16:46:26 +1000
committerEdward O'Callaghan <quasisec@chromium.org>2020-06-16 02:25:17 +0000
commit41f48c75a2a708407e8c28f85eff04cbf2895f3c (patch)
treea8e51b7b3358f34be224ce388f5a2fc7ccf77d69 /tests/meson.build
parent46f2d4e488db66b37e892b8fa621eeed0fe2f284 (diff)
downloadflashrom-41f48c75a2a708407e8c28f85eff04cbf2895f3c.tar.gz
flashrom-41f48c75a2a708407e8c28f85eff04cbf2895f3c.tar.bz2
flashrom-41f48c75a2a708407e8c28f85eff04cbf2895f3c.zip
tests/: Add spi25.c unit tests
BUG=b:157280555 BRANCH=none TEST=builds Change-Id: I47112952835ce2c4c773a9d90379ff8ceefaaf9a Signed-off-by: Edward O'Callaghan <quasisec@google.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/41645 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Stefan Reinauer <stefan.reinauer@coreboot.org>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 0c21cb9c..76088c27 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -2,11 +2,13 @@ root_includes = include_directories('../subprojects')
srcs = [
'tests.c',
+ 'spi25.c',
]
mocks = [
'-Wl,--wrap=physunmap',
'-Wl,--wrap=physmap',
+ '-Wl,--wrap=spi_send_command',
'-Wl,--gc-sections',
]