aboutsummaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorPeter Marheine <pmarheine@chromium.org>2021-08-10 15:38:47 +1000
committerEdward O'Callaghan <quasisec@chromium.org>2021-08-19 03:53:41 +0000
commit47f4c18260e1eff46b0605b1039166238fc4797c (patch)
tree4c0ba8d00f032f19bf83c2427e163a7a3f07b55e /tests/meson.build
parentb261bec1eea70aa67966b7f3ed36d4ae61cc31e0 (diff)
downloadflashrom-47f4c18260e1eff46b0605b1039166238fc4797c.tar.gz
flashrom-47f4c18260e1eff46b0605b1039166238fc4797c.tar.bz2
flashrom-47f4c18260e1eff46b0605b1039166238fc4797c.zip
tests: add init_shutdown test for realtek_mst_i2c_spi
This can catch regressions like the earlier one in this programmer that caused initialization to always fail. Requires support for mocking POSIX file I/O functions because the programmer does ioctls on the opened file. TEST=ninja test Signed-off-by: Peter Marheine <pmarheine@chromium.org> Change-Id: I5a5c617d1ec35d2a3bbe622e5add82a65eb396f0 Reviewed-on: https://review.coreboot.org/c/flashrom/+/56911 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 9fb86c71..2bde3f01 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -34,6 +34,8 @@ mocks = [
'-Wl,--wrap=open',
'-Wl,--wrap=open64',
'-Wl,--wrap=ioctl',
+ '-Wl,--wrap=read',
+ '-Wl,--wrap=write',
'-Wl,--wrap=fopen',
'-Wl,--wrap=fopen64',
'-Wl,--wrap=rget_io_perms',