aboutsummaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorAnastasia Klimchuk <aklm@chromium.org>2021-04-21 07:58:30 +1000
committerNico Huber <nico.h@gmx.de>2021-04-27 12:46:45 +0000
commitcffaac1e0f802e3fe27c4997e931586ee738f94a (patch)
treea454b3319888785615fdf98bd6e2a1d64cdc11f9 /tests/meson.build
parentab9d1460bad85d598e73adf08ec6209fc70d1014 (diff)
downloadflashrom-cffaac1e0f802e3fe27c4997e931586ee738f94a.tar.gz
flashrom-cffaac1e0f802e3fe27c4997e931586ee738f94a.tar.bz2
flashrom-cffaac1e0f802e3fe27c4997e931586ee738f94a.zip
tests: Add unit test to run init/shutdown for dummyflasher.c
Introduce test to exercise that init and shutdown of drivers correctly manage the drivers life-time state. We constrain ourselves to dummyflasher in particular here as it does not need any mocking. BUG=b:181803212 TEST=builds and ninja test Change-Id: I3c0ef73397f00c1db7aabb5f9f00cb43525af29c Signed-off-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/52497 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index f0cb76dd..815ea766 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -18,6 +18,7 @@ srcs = [
'helpers.c',
'flashrom.c',
'spi25.c',
+ 'init_shutdown.c',
]
mocks = [