aboutsummaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorAnastasia Klimchuk <aklm@chromium.org>2022-06-02 11:56:38 +1000
committerAnastasia Klimchuk <aklm@chromium.org>2022-06-21 00:31:52 +0000
commitfac9fc28f5a6cadf7c94264f429faa597a2058ac (patch)
treebf95f4d8c5762599774ffc0e309aae7a0b76cd0c /tests/meson.build
parent3c8166e50b1f2eeba45662b29f7cc8823e198d8d (diff)
downloadflashrom-fac9fc28f5a6cadf7c94264f429faa597a2058ac.tar.gz
flashrom-fac9fc28f5a6cadf7c94264f429faa597a2058ac.tar.bz2
flashrom-fac9fc28f5a6cadf7c94264f429faa597a2058ac.zip
tests: Use regular cmocka wraps for hwaccess functions
hwaccess functions used to be static inline functions and needed a special treatment so that they could be mocked for unit tests. This has changed, see include/hwaccess_x86_io.h now the functions are not static inline anymore, and it is possible to use regular cmocka wraps. Fixes https://ticket.coreboot.org/issues/385 BUG=b:181803212 TEST=ninja test Change-Id: Iafce071ea7ad5bcfdebbba968699d5743705f8e0 Signed-off-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/64881 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Joursoir <chat@joursoir.net> Reviewed-by: Thomas Heijligen <src@posteo.de>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 588ac17f..38f5be56 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -67,12 +67,12 @@ mocks = [
'-Wl,--wrap=clearerr',
'-Wl,--wrap=setvbuf',
'-Wl,--wrap=rget_io_perms',
- '-Wl,--wrap=test_outb',
- '-Wl,--wrap=test_inb',
- '-Wl,--wrap=test_outw',
- '-Wl,--wrap=test_inw',
- '-Wl,--wrap=test_outl',
- '-Wl,--wrap=test_inl',
+ '-Wl,--wrap=OUTB',
+ '-Wl,--wrap=INB',
+ '-Wl,--wrap=OUTW',
+ '-Wl,--wrap=INW',
+ '-Wl,--wrap=OUTL',
+ '-Wl,--wrap=INL',
'-Wl,--wrap=usb_dev_get_by_vid_pid_number',
'-Wl,--wrap=libusb_init',
'-Wl,--wrap=libusb_open',