aboutsummaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
authorAnastasia Klimchuk <aklm@chromium.org>2021-07-15 10:04:39 +1000
committerEdward O'Callaghan <quasisec@chromium.org>2021-07-19 04:42:01 +0000
commit35e8bf64a7f11b7dd51fa62918088ba8aa2b9742 (patch)
tree770810b4b31fcfaacc81f9893332d452a3f21a96 /tests
parent80c3296499b841b2a5a1b6fe82d4378dab331cca (diff)
downloadflashrom-35e8bf64a7f11b7dd51fa62918088ba8aa2b9742.tar.gz
flashrom-35e8bf64a7f11b7dd51fa62918088ba8aa2b9742.tar.bz2
flashrom-35e8bf64a7f11b7dd51fa62918088ba8aa2b9742.zip
tests: Add layout tests for overlapping regions
There are no tests for layout, it would be great to add some. Also partially inspired by commit 06a89d713951a2e08ef8fb698a7688357baa83d1 and commit c9039fc27916c03e21ba91365d01e6bc49503053 BUG=b:193584590 TEST=ninja test Change-Id: I7aa8dc0c9bc5a22fe5deea757eea1a151b969cea Signed-off-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/56324 Reviewed-by: Edward O'Callaghan <quasisec@chromium.org> Reviewed-by: Angel Pons <th3fanbus@gmail.com> Tested-by: build bot (Jenkins) <no-reply@coreboot.org>
Diffstat (limited to 'tests')
-rw-r--r--tests/layout.c103
-rw-r--r--tests/meson.build1
-rw-r--r--tests/tests.c7
-rw-r--r--tests/tests.h5
4 files changed, 116 insertions, 0 deletions
diff --git a/tests/layout.c b/tests/layout.c
new file mode 100644
index 00000000..e3e95394
--- /dev/null
+++ b/tests/layout.c
@@ -0,0 +1,103 @@
+/*
+ * This file is part of the flashrom project.
+ *
+ * Copyright 2021 Google LLC
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; version 2 of the License.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ */
+
+#include <include/test.h>
+#include <stdio.h>
+
+#include "layout.h"
+#include "libflashrom.h"
+
+void included_regions_dont_overlap_test_success(void **state)
+{
+ (void) state; /* unused */
+
+ printf("Creating layout...\n");
+ struct flashrom_layout *layout;
+ assert_int_equal(0, flashrom_layout_new(&layout));
+ printf("done\n");
+
+ printf("Adding and including first region...\n");
+ assert_int_equal(0, flashrom_layout_add_region(layout, 0x00021000, 0x00031000, "first region"));
+ assert_int_equal(0, flashrom_layout_include_region(layout, "first region"));
+ printf("done\n");
+
+ printf("Adding and including second (non-overlapping) region...\n");
+ assert_int_equal(0, flashrom_layout_add_region(layout, 0x00031001, 0x0023efc0, "second region"));
+ assert_int_equal(0, flashrom_layout_include_region(layout, "second region"));
+ printf("done\n");
+
+ printf("Asserting included regions do not overlap...\n");
+ assert_int_equal(0, included_regions_overlap(layout));
+ printf("done\n");
+
+ printf("Releasing layout...\n");
+ flashrom_layout_release(layout);
+ printf("done\n");
+}
+
+void included_regions_overlap_test_success(void **state)
+{
+ (void) state; /* unused */
+
+ printf("Creating layout...\n");
+ struct flashrom_layout *layout;
+ assert_int_equal(0, flashrom_layout_new(&layout));
+ printf("done\n");
+
+ printf("Adding and including first region...\n");
+ assert_int_equal(0, flashrom_layout_add_region(layout, 0x00021000, 0x00031000, "first region"));
+ assert_int_equal(0, flashrom_layout_include_region(layout, "first region"));
+ printf("done\n");
+
+ printf("Adding and including second (overlapping) region...\n");
+ assert_int_equal(0, flashrom_layout_add_region(layout, 0x00027100, 0x0023efc0, "second region"));
+ assert_int_equal(0, flashrom_layout_include_region(layout, "second region"));
+ printf("done\n");
+
+ printf("Asserting included regions overlap...\n");
+ assert_int_equal(1, included_regions_overlap(layout));
+ printf("done\n");
+
+ printf("Releasing layout...\n");
+ flashrom_layout_release(layout);
+ printf("done\n");
+}
+
+void region_not_included_overlap_test_success(void **state)
+{
+ (void) state; /* unused */
+
+ printf("Creating layout...\n");
+ struct flashrom_layout *layout;
+ assert_int_equal(0, flashrom_layout_new(&layout));
+ printf("done\n");
+
+ printf("Adding and including first region...\n");
+ assert_int_equal(0, flashrom_layout_add_region(layout, 0x00021000, 0x00031000, "first region"));
+ assert_int_equal(0, flashrom_layout_include_region(layout, "first region"));
+ printf("done\n");
+
+ printf("Adding second (overlapping) region, not included...\n");
+ assert_int_equal(0, flashrom_layout_add_region(layout, 0x00027100, 0x0023efc0, "second region"));
+ printf("done\n");
+
+ printf("Asserting included regions do not overlap...\n");
+ assert_int_equal(0, included_regions_overlap(layout));
+ printf("done\n");
+
+ printf("Releasing layout...\n");
+ flashrom_layout_release(layout);
+ printf("done\n");
+}
diff --git a/tests/meson.build b/tests/meson.build
index 0bc05607..5776862d 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -19,6 +19,7 @@ srcs = [
'flashrom.c',
'spi25.c',
'init_shutdown.c',
+ 'layout.c',
]
mocks = [
diff --git a/tests/tests.c b/tests/tests.c
index 592d896c..78258b03 100644
--- a/tests/tests.c
+++ b/tests/tests.c
@@ -236,5 +236,12 @@ int main(void)
};
ret |= cmocka_run_group_tests_name("init_shutdown.c tests", init_shutdown_tests, NULL, NULL);
+ const struct CMUnitTest layout_tests[] = {
+ cmocka_unit_test(included_regions_dont_overlap_test_success),
+ cmocka_unit_test(included_regions_overlap_test_success),
+ cmocka_unit_test(region_not_included_overlap_test_success),
+ };
+ ret |= cmocka_run_group_tests_name("layout.c tests", layout_tests, NULL, NULL);
+
return ret;
}
diff --git a/tests/tests.h b/tests/tests.h
index 20076959..eccc05fd 100644
--- a/tests/tests.h
+++ b/tests/tests.h
@@ -47,4 +47,9 @@ void dediprog_init_and_shutdown_test_success(void **state);
void ene_lpc_init_and_shutdown_test_success(void **state);
void linux_spi_init_and_shutdown_test_success(void **state);
+/* layout.c */
+void included_regions_dont_overlap_test_success(void **state);
+void included_regions_overlap_test_success(void **state);
+void region_not_included_overlap_test_success(void **state);
+
#endif /* TESTS_H */