aboutsummaryrefslogtreecommitdiffstats
path: root/util/flashrom_tester/Cargo.toml
diff options
context:
space:
mode:
authorEvan Benn <evanbenn@chromium.org>2022-11-07 16:48:14 +1100
committerEdward O'Callaghan <quasisec@chromium.org>2022-11-17 04:28:20 +0000
commit4df64d93a063ddbfbf9d05f7059fe8386385132a (patch)
tree5cd0add9eef87af488bdff5079acfd5ee0466560 /util/flashrom_tester/Cargo.toml
parent065366dd278d5a2e220c9aa2667296580d414cab (diff)
downloadflashrom-4df64d93a063ddbfbf9d05f7059fe8386385132a.tar.gz
flashrom-4df64d93a063ddbfbf9d05f7059fe8386385132a.tar.bz2
flashrom-4df64d93a063ddbfbf9d05f7059fe8386385132a.zip
flashrom_tester: Only print color when stdout isatty
Add the atty crate as a dependency. Print log and report in color only when isatty is true. BUG=b:246250254 BRANCH=None TEST=ssh dut flashrom_tester # no color TEST=ssh -t dut flashrom_tester # color Change-Id: Ia3cc527fb98e53eda6773622340cf10764df2cba Signed-off-by: Evan Benn <evanbenn@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/69270 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Angel Pons <th3fanbus@gmail.com> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'util/flashrom_tester/Cargo.toml')
-rw-r--r--util/flashrom_tester/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/util/flashrom_tester/Cargo.toml b/util/flashrom_tester/Cargo.toml
index b57f04e5..a7b68813 100644
--- a/util/flashrom_tester/Cargo.toml
+++ b/util/flashrom_tester/Cargo.toml
@@ -14,6 +14,7 @@ name = "flashrom_tester"
required-features = ["cli"]
[dependencies]
+atty = "0.2"
built = { version = "0.5", features = ["chrono"] }
chrono = { version = "0.4", optional = true }
clap = { version = "2.33", default-features = false, optional = true }