aboutsummaryrefslogtreecommitdiffstats
path: root/util/manibuilder
diff options
context:
space:
mode:
authorNico Huber <nico.h@gmx.de>2019-06-08 23:05:52 +0200
committerAngel Pons <th3fanbus@gmail.com>2021-03-16 10:12:17 +0000
commitada8de029b8799148d7e37359c1f908b29a51443 (patch)
treeaeb268d982f0b7a9be5a58492c9f3cd9ad1fe368 /util/manibuilder
parent9785652e5ed61e544d727b3517f63ffc02de7c8c (diff)
downloadflashrom-ada8de029b8799148d7e37359c1f908b29a51443.tar.gz
flashrom-ada8de029b8799148d7e37359c1f908b29a51443.tar.bz2
flashrom-ada8de029b8799148d7e37359c1f908b29a51443.zip
manibuilder: Add list of tags used for the 1.1.x branch
Change-Id: I243aa11f4a017a4209efcc227cec56eb12020e28 Signed-off-by: Nico Huber <nico.h@gmx.de> Reviewed-on: https://review.coreboot.org/c/flashrom/+/33340 Reviewed-by: Angel Pons <th3fanbus@gmail.com> Reviewed-by: David Hendricks <david.hendricks@gmail.com> Tested-by: build bot (Jenkins) <no-reply@coreboot.org>
Diffstat (limited to 'util/manibuilder')
-rw-r--r--util/manibuilder/Makefile.targets57
1 files changed, 55 insertions, 2 deletions
diff --git a/util/manibuilder/Makefile.targets b/util/manibuilder/Makefile.targets
index f5a142c3..b41e3517 100644
--- a/util/manibuilder/Makefile.targets
+++ b/util/manibuilder/Makefile.targets
@@ -118,6 +118,53 @@ DEFAULT_TAGS += $(filter-out $(DEFAULT_TAGS),$(NATIVE_TAGS))
# can only run what is still maintained
10X_TAGS := $(filter $(10X_TAGS),$(ALL_TAGS))
+# original 1.1.x tags
+11X_TAGS := \
+ anita\:amd64 \
+ djgpp\:6.1.0 \
+ fedora\:30-x86_64 \
+ fedora\:30-aarch64 \
+ fedora\:29-x86_64 \
+ fedora\:25-x86_64 \
+ fedora\:25-ppc64le \
+ fedora\:25-aarch64 \
+ fedora\:24-x86_64 \
+ centos\:7.6-amd64-clean \
+ centos\:7.3-aarch64-clean \
+ centos\:7.3-amd64-clean \
+ centos\:7.2-amd64-clean \
+ debian-debootstrap\:ppc64el-stretch \
+ debian-debootstrap\:armhf-stretch \
+ debian-debootstrap\:mips-stretch \
+ debian-debootstrap\:mipsel-stretch \
+ debian-debootstrap\:amd64-stretch \
+ debian-debootstrap\:i386-stretch \
+ debian-debootstrap\:amd64-sid \
+ ubuntu-debootstrap\:arm64-xenial \
+ ubuntu-debootstrap\:amd64-xenial \
+ ubuntu-debootstrap\:powerpc-xenial \
+ ubuntu-debootstrap\:amd64-bionic \
+ alpine\:aarch64-v3.9 \
+ alpine\:amd64-v3.9 \
+ alpine\:amd64-v3.8 \
+ alpine\:amd64-v3.7 \
+ alpine\:amd64-v3.6 \
+ alpine\:armhf-v3.8 \
+ alpine\:i386-v3.9 \
+ alpine\:i386-v3.8 \
+ alpine\:i386-v3.7 \
+ alpine\:i386-v3.6 \
+ debian-debootstrap\:amd64-buster \
+ debian-debootstrap\:i386-buster \
+ debian-debootstrap\:i386-sid \
+ ubuntu-debootstrap\:armhf-xenial \
+ ubuntu-debootstrap\:i386-bionic \
+ ubuntu-debootstrap\:i386-xenial \
+ ubuntu-debootstrap\:ppc64el-xenial \
+
+# can only run what is still maintained
+11X_TAGS := $(filter $(11X_TAGS),$(ALL_TAGS))
+
default: $(DEFAULT_TAGS)
native: $(NATIVE_TAGS)
@@ -127,6 +174,9 @@ all: $(ALL_TAGS)
1.0.x: export TEST_REVISION=refs/heads/1.0.x
1.0.x: $(10X_TAGS)
+1.1.x: export TEST_REVISION=refs/heads/1.1.x
+1.1.x: $(11X_TAGS)
+
show-default:
@printf "%s\n" $(DEFAULT_TAGS)
@@ -139,6 +189,9 @@ show-all:
show-1.0.x:
@printf "%s\n" $(10X_TAGS)
-.PHONY: default native all 1.0.x
-.PHONY: show-default show-native show-all show-1.0.x
+show-1.1.x:
+ @printf "%s\n" $(11X_TAGS)
+
+.PHONY: default native all 1.0.x 1.1.x
+.PHONY: show-default show-native show-all show-1.0.x show-1.1.x
.PHONY: $(ALL_TAGS)