aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--dmi.c2
2 files changed, 1 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index d496a9a3..dd19e141 100644
--- a/Makefile
+++ b/Makefile
@@ -30,7 +30,7 @@ INSTALL = install
DIFF = diff
PREFIX ?= /usr/local
MANDIR ?= $(PREFIX)/share/man
-CFLAGS ?= -std=c99 -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200809L -D_BSD_SOURCE -Os -Wall -Wextra -Wno-unused-parameter -Wshadow -Wmissing-prototypes -Wwrite-strings
+CFLAGS ?= -Os -Wall -Wextra -Wno-unused-parameter -Wshadow -Wmissing-prototypes -Wwrite-strings
EXPORTDIR ?= .
RANLIB ?= ranlib
PKG_CONFIG ?= pkg-config
diff --git a/dmi.c b/dmi.c
index 55edb033..e449cd9f 100644
--- a/dmi.c
+++ b/dmi.c
@@ -19,9 +19,7 @@
/* strnlen is in POSIX but was a GNU extension up to glibc 2.10 */
#if (__GLIBC__ == 2 && __GLIBC_MINOR__ < 10) || __GLIBC__ < 2
-#ifndef _GNU_SOURCE
#define _GNU_SOURCE
-#endif /* !GNU_SOURCE */
#else
#define _POSIX_C_SOURCE 200809L
#endif