aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--meson.build2
-rw-r--r--platform.h13
-rw-r--r--platform/memaccess.c42
4 files changed, 58 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f94f0468..bfa9c679 100644
--- a/Makefile
+++ b/Makefile
@@ -378,7 +378,7 @@ CHIP_OBJS = jedec.o stm50.o w39.o w29ee011.o \
# Library code.
LIB_OBJS = libflashrom.o layout.o flashrom.o udelay.o programmer.o programmer_table.o \
- helpers.o ich_descriptors.o fmap.o platform/endian_$(ENDIAN).o
+ helpers.o ich_descriptors.o fmap.o platform/endian_$(ENDIAN).o platform/memaccess.o
###############################################################################
diff --git a/meson.build b/meson.build
index c84c5ded..5a6bc2ad 100644
--- a/meson.build
+++ b/meson.build
@@ -135,6 +135,8 @@ if cc.check_header('sys/utsname.h')
add_project_arguments('-DHAVE_UTSNAME=1', language : 'c')
endif
+srcs += 'platform/memaccess.c'
+
if host_machine.endian() == 'little'
srcs += 'platform/endian_little.c'
add_project_arguments('-D__FLASHROM_LITTLE_ENDIAN__=1', language : 'c')
diff --git a/platform.h b/platform.h
index 4f2a4c17..cf73c292 100644
--- a/platform.h
+++ b/platform.h
@@ -22,6 +22,7 @@
#ifndef __PLATFORM_H__
#define __PLATFORM_H__ 1
+#include <stddef.h>
#include <stdint.h>
/* swap bytes */
@@ -100,4 +101,16 @@ uint16_t be_to_cpu16(uint16_t value);
uint32_t be_to_cpu32(uint32_t value);
uint64_t be_to_cpu64(uint64_t value);
+/* read value from base at offset in little endian */
+uint8_t read_le8 (const void *base, size_t offset);
+uint16_t read_le16(const void *base, size_t offset);
+uint32_t read_le32(const void *base, size_t offset);
+uint64_t read_le64(const void *base, size_t offset);
+
+/* read value from base at offset in big endian */
+uint8_t read_be8 (const void *base, size_t offset);
+uint16_t read_be16(const void *base, size_t offset);
+uint32_t read_be32(const void *base, size_t offset);
+uint64_t read_be64(const void *base, size_t offset);
+
#endif /* !__PLATFORM_H__ */
diff --git a/platform/memaccess.c b/platform/memaccess.c
new file mode 100644
index 00000000..44ef4108
--- /dev/null
+++ b/platform/memaccess.c
@@ -0,0 +1,42 @@
+/*
+ * This file is part of the flashrom project.
+ *
+ * Copyright (C) 2016 secunet Security Networks AG
+ * (written by Thomas Heijligen <thomas.heijligen@secunet.com>)
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ */
+
+#include "../platform.h"
+
+/*
+ * macro to return endian aware read function
+ *
+ * `___read(le, 8)`
+ * expands to
+ * `uint8_t read_le8 (const void *const base, const size_t offset)
+ * { return le_to_cpu8 (*(uint8_t *)((uintptr_t)base + offset)); }`
+ */
+#define ___read(endian, bits) \
+ uint##bits##_t read_##endian##bits (const void *const base, const size_t offset) \
+ { return endian##_to_cpu##bits (*(uint##bits##_t *)((uintptr_t)base + offset)); }
+
+/* read value from base at offset in little endian */
+___read(le, 8)
+___read(le, 16)
+___read(le, 32)
+___read(le, 64)
+
+/* read value from base at offset in big endian */
+___read(be, 8)
+___read(be, 16)
+___read(be, 32)
+___read(be, 64)