aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--Makefile.d/arch_test.h2
2 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f73d1440..a16f3512 100644
--- a/Makefile
+++ b/Makefile
@@ -363,7 +363,7 @@ endif
# Additionally disable all drivers needing raw access (memory, PCI, port I/O)
# on architectures with unknown raw access properties.
# Right now those architectures are alpha hppa m68k sh s390
-ifneq ($(ARCH), $(filter $(ARCH), x86 mips ppc arm sparc arc))
+ifneq ($(ARCH), $(filter $(ARCH), x86 mips ppc arm sparc arc e2k))
$(call mark_unsupported,$(DEPENDS_ON_RAW_MEM_ACCESS))
endif
diff --git a/Makefile.d/arch_test.h b/Makefile.d/arch_test.h
index 077aabac..2b988efd 100644
--- a/Makefile.d/arch_test.h
+++ b/Makefile.d/arch_test.h
@@ -45,6 +45,8 @@
#define __FLASHROM_ARCH__ "s390"
#elif defined(__arc__)
#define __FLASHROM_ARCH__ "arc"
+#elif defined(__e2k__)
+ #define __FLASHROM_ARCH__ "e2k"
#else
#define __FLASHROM_ARCH__ "unknown"
#endif