aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2020-05-22 06:52:48 +0200
committerTristan Gingold <tgingold@free.fr>2020-05-22 06:52:48 +0200
commit29bf7356c3033b076adc9b81ffe1f55c78088d81 (patch)
tree425ae0d33d59b0f0d6d7657fb77ed251158276f9
parent9b22f648af5d4e14257dc59630b50859db97c3bb (diff)
downloadghdl-yosys-plugin-29bf7356c3033b076adc9b81ffe1f55c78088d81.tar.gz
ghdl-yosys-plugin-29bf7356c3033b076adc9b81ffe1f55c78088d81.tar.bz2
ghdl-yosys-plugin-29bf7356c3033b076adc9b81ffe1f55c78088d81.zip
README.md: remove static build instructions.
Was not working anymore.
-rw-r--r--README.md19
-rw-r--r--yosys.diff45
2 files changed, 0 insertions, 64 deletions
diff --git a/README.md b/README.md
index 9e886f9..e0cbcc0 100644
--- a/README.md
+++ b/README.md
@@ -13,7 +13,6 @@
**This is experimental and work in progress!** See [ghdl.rtfd.io: Using/Synthesis](http://ghdl.readthedocs.io/en/latest/using/Synthesis.html).
- [Build as a module (shared library)](#build-as-a-module-shared-library)
-- [Build as part of yosys (not recommended)](#build-as-part-of-yosys-not-recommended)
- [Usage](#Usage)
- [Docker](#Docker)
@@ -47,24 +46,6 @@ yosys-config --exec mkdir -p --datdir/plugins
yosys-config --exec ln -s "$GHDL_PREFIX/lib/ghdl_yosys.so" --datdir/plugins/ghdl.so
```
-## Build as part of yosys (not recommended)
-
-- Get and build ghdl as in the previous section.
-
-- Get [yosys](https://github.com/YosysHQ/yosys) sources.
-
-- Get ghdl-yosys-plugin and:
- - Patch yosys sources using `yosys.diff`.
- - Copy `src/*` to `yosys/frontends/ghdl`.
- - Configure yosys by adding (to) `Makefile.conf`:
-
-```makefile
-ENABLE_GHDL := 1
-GHDL_DIR := <ghdl install dir>
-```
-
-- Build and install yosys.
-
## Usage
Example for icestick, using ghdl, yosys, nextpnr and icestorm:
diff --git a/yosys.diff b/yosys.diff
deleted file mode 100644
index 942ddca..0000000
--- a/yosys.diff
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/Makefile b/Makefile
-index aba7775..9836831 100644
---- a/Makefile
-+++ b/Makefile
-@@ -14,6 +14,7 @@ ENABLE_READLINE := 1
- ENABLE_VERIFIC := 0
- ENABLE_COVER := 1
- ENABLE_LIBYOSYS := 0
-+ENABLE_GHDL := 0
-
- # other configuration flags
- ENABLE_GPROF := 0
-@@ -49,7 +50,7 @@ all: top-all
- YOSYS_SRC := $(dir $(firstword $(MAKEFILE_LIST)))
- VPATH := $(YOSYS_SRC)
-
--CXXFLAGS += -Wall -Wextra -ggdb -I. -I"$(YOSYS_SRC)" -MD -D_YOSYS_ -fPIC -I$(PREFIX)/include
-+CXXFLAGS += -Wall -Wextra -g -I. -I"$(YOSYS_SRC)" -MD -D_YOSYS_ -I$(PREFIX)/include
- LDFLAGS += -L$(LIBDIR)
- LDLIBS = -lstdc++ -lm
-
-@@ -104,7 +105,7 @@ endif
- ifeq ($(CONFIG),clang)
- CXX = clang
- LD = clang++
--CXXFLAGS += -std=c++11 -Os
-+CXXFLAGS += -std=c++11 # -Os
-
- ifneq ($(SANITIZER),)
- $(info [Clang Sanitizer] $(SANITIZER))
-@@ -236,6 +237,14 @@ CXXFLAGS += $(patsubst %,-I$(VERIFIC_DIR)/%,$(VERIFIC_COMPONENTS)) -DYOSYS_ENABL
- LDLIBS += $(patsubst %,$(VERIFIC_DIR)/%/*-linux.a,$(VERIFIC_COMPONENTS))
- endif
-
-+ifeq ($(ENABLE_GHDL),1)
-+GHDL_DIR ?= /usr/local/ghdl
-+GHDL_INCLUDE_DIR ?= $(GHDL_DIR)/include
-+GHDL_LIB_DIR ?= $(GHDL_DIR)/lib
-+CXXFLAGS += -I$(GHDL_INCLUDE_DIR) -DYOSYS_ENABLE_GHDL
-+LDLIBS += $(GHDL_LIB_DIR)/libghdlsynth.a $(shell cat $(GHDL_LIB_DIR)/ghdlsynth.link)
-+endif
-+
- ifeq ($(ENABLE_COVER),1)
- CXXFLAGS += -DYOSYS_ENABLE_COVER
- endif