diff options
author | 1138-4EB <1138-4EB@users.noreply.github.com> | 2019-08-16 22:07:46 +0200 |
---|---|---|
committer | tgingold <tgingold@users.noreply.github.com> | 2019-08-16 22:07:46 +0200 |
commit | d359d6deb55e5c51707c86263b090fabbc5c41b2 (patch) | |
tree | e916cb1f11ec2687bfedbd6ad02f08c3a5b068db /Makefile | |
parent | c924837dd7f9164aabb37983fb036ee34a9f1e40 (diff) | |
download | ghdl-yosys-plugin-d359d6deb55e5c51707c86263b090fabbc5c41b2.tar.gz ghdl-yosys-plugin-d359d6deb55e5c51707c86263b090fabbc5c41b2.tar.bz2 ghdl-yosys-plugin-d359d6deb55e5c51707c86263b090fabbc5c41b2.zip |
Run testsuite in Travis CI with docker images (#31)
* makefile: use '--build' shortcut to build ghdl.so
* move: rename subdir 'ghdl' to 'src'
* travis: add travis config file, build script and utils script
* testsuite: do not call ghdl explicitly
* readme: update
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 8 |
1 files changed, 3 insertions, 5 deletions
@@ -16,15 +16,13 @@ ALL_LDFLAGS=$(LIBGHDL_LIB) -Wl,-rpath,$(dir $(LIBGHDL_LIB)) $(LDFLAGS) ALL_CFLAGS=-fPIC -DYOSYS_ENABLE_GHDL -I$(LIBGHDL_INC) $(CFLAGS) -COMPILE=$(YOSYS_CONFIG) --exec --cxx - all: ghdl.$(SOEXT) ghdl.$(SOEXT): ghdl.o - $(COMPILE) -o $@ -shared $< $(ALL_LDFLAGS) --ldflags --ldlibs + $(YOSYS_CONFIG) --build $@ $< -shared $(ALL_LDFLAGS) -ghdl.o: ghdl/ghdl.cc - $(COMPILE) -c --cxxflags -o $@ $< $(ALL_CFLAGS) +ghdl.o: src/ghdl.cc + $(YOSYS_CONFIG) --exec --cxx -c --cxxflags -o $@ $< $(ALL_CFLAGS) clean: force $(RM) -f ghdl.$(SOEXT) ghdl.o |