aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--ghdl/ghdl.cc2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 60b65da..72c297e 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ SOEXT=so
LDFLAGS=
CFLAGS=-O
-ALL_LDFLAGS=$(GHDL_PREFIX)/lib/libghdlsynth.so -Wl,-rpath,$(GHDL_PREFIX)/lib $(LDFLAGS)
+ALL_LDFLAGS=$(GHDL_PREFIX)/lib/libghdl-*.so -Wl,-rpath,$(GHDL_PREFIX)/lib $(LDFLAGS)
ALL_CFLAGS=-fPIC -DYOSYS_ENABLE_GHDL -I$(GHDL_PREFIX)/include $(CFLAGS)
diff --git a/ghdl/ghdl.cc b/ghdl/ghdl.cc
index 0fc1d0a..c5420e1 100644
--- a/ghdl/ghdl.cc
+++ b/ghdl/ghdl.cc
@@ -536,7 +536,7 @@ struct GhdlPass : public Pass {
log_header(design, "Executing GHDL.\n");
// Initialize the library. There is a counter in that function that protects against multiple calls.
- libghdlsynth_init ();
+ libghdl_init ();
if (args.size() == 2 && args[1] == "--disp-config") {
ghdlcomp__disp_config();