aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2020-01-12 17:34:37 +0100
committerTristan Gingold <tgingold@free.fr>2020-01-12 17:34:37 +0100
commit2cf549f4997436ca8553da1e733f35623eb5c38b (patch)
treed34aa6824392f624bf993a09084e735b41890c5b
parent2766fa3e7a7917889aa41a816aaff9105bfd8dd5 (diff)
downloadghdl-2cf549f4997436ca8553da1e733f35623eb5c38b.tar.gz
ghdl-2cf549f4997436ca8553da1e733f35623eb5c38b.tar.bz2
ghdl-2cf549f4997436ca8553da1e733f35623eb5c38b.zip
msys2-mingw: build llvm with --static-link (tentatively fix ci)
-rw-r--r--dist/msys2-mingw/llvm/PKGBUILD2
-rw-r--r--src/ortho/llvm4-nodebug/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/dist/msys2-mingw/llvm/PKGBUILD b/dist/msys2-mingw/llvm/PKGBUILD
index 0f6ebf9af..a947aa1e3 100644
--- a/dist/msys2-mingw/llvm/PKGBUILD
+++ b/dist/msys2-mingw/llvm/PKGBUILD
@@ -17,7 +17,7 @@ makedepends=("${MINGW_PACKAGE_PREFIX}-clang" "${MINGW_PACKAGE_PREFIX}-gcc-ada")
build() {
mkdir "${srcdir}/builddir"
cd "${srcdir}/builddir"
- ../../../../../configure --prefix=${MINGW_PREFIX} --with-llvm-config LDFLAGS=-static --enable-libghdl --enable-synth
+ ../../../../../configure --prefix=${MINGW_PREFIX} --with-llvm-config="llvm-config --link-static" LDFLAGS="-static" --enable-libghdl --enable-synth
make GNATMAKE="gnatmake -j$(nproc)"
}
diff --git a/src/ortho/llvm4-nodebug/Makefile b/src/ortho/llvm4-nodebug/Makefile
index fc10e23de..b40bb2cc8 100644
--- a/src/ortho/llvm4-nodebug/Makefile
+++ b/src/ortho/llvm4-nodebug/Makefile
@@ -6,7 +6,7 @@ GNATMAKE=gnatmake
SED=sed
BE=llvm4-nodebug
-LLVM_LDFLAGS=$(LLVM_CONFIG) --link-static --ldflags --libs --system-libs
+LLVM_LDFLAGS=$(LLVM_CONFIG) --ldflags --libs --system-libs
all: $(ortho_exec)