aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2019-06-29 03:59:12 +0200
committerTristan Gingold <tgingold@free.fr>2019-06-29 08:36:31 +0200
commit5fc2b23c0a27e281d3c1f1927379aa1fd9300df0 (patch)
tree1c1f16096d2cd01ce54e61b4e6e8ffb186a2d8fb
parent655866865db5d5c259a87105807dc7aed0d857d7 (diff)
downloadghdl-5fc2b23c0a27e281d3c1f1927379aa1fd9300df0.tar.gz
ghdl-5fc2b23c0a27e281d3c1f1927379aa1fd9300df0.tar.bz2
ghdl-5fc2b23c0a27e281d3c1f1927379aa1fd9300df0.zip
ghdl_jit: almost add ghdlsynth
-rw-r--r--Makefile.in2
-rw-r--r--src/areapools.adb (renamed from src/vhdl/simulate/areapools.adb)0
-rw-r--r--src/areapools.ads (renamed from src/vhdl/simulate/areapools.ads)0
-rw-r--r--src/ghdldrv/ghdl_jit.adb2
4 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 1deebcb96..0ffe52bc6 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -177,7 +177,7 @@ version.ads: version.tmp
all.mcode: ghdl_mcode$(EXEEXT) libs.vhdl.mcode all.vpi
-GHDL_MCODE_INCFLAGS=$(GHDL_COMMON_INCFLAGS) -aI$(srcdir)/src/ghdldrv -aI$(srcdir)/src/ortho -aI$(srcdir)/src/ortho/mcode
+GHDL_MCODE_INCFLAGS=$(GHDL_COMMON_INCFLAGS) -aI$(srcdir)/src/ghdldrv -aI$(srcdir)/src/ortho -aI$(srcdir)/src/ortho/mcode -aI$(srcdir)/src/synth
ghdl_mcode$(EXEEXT): GRT_FLAGS+=-DWITH_GNAT_RUN_TIME
ghdl_mcode$(EXEEXT): $(GRT_ADD_OBJS) $(GRT_SRC_DEPS) $(ORTHO_DEPS) \
diff --git a/src/vhdl/simulate/areapools.adb b/src/areapools.adb
index 341b14240..341b14240 100644
--- a/src/vhdl/simulate/areapools.adb
+++ b/src/areapools.adb
diff --git a/src/vhdl/simulate/areapools.ads b/src/areapools.ads
index 186f29707..186f29707 100644
--- a/src/vhdl/simulate/areapools.ads
+++ b/src/areapools.ads
diff --git a/src/ghdldrv/ghdl_jit.adb b/src/ghdldrv/ghdl_jit.adb
index d17e7fad4..5da726e10 100644
--- a/src/ghdldrv/ghdl_jit.adb
+++ b/src/ghdldrv/ghdl_jit.adb
@@ -21,6 +21,7 @@ with Ghdlprint;
with Ghdlrun;
with Ghdlvpi;
with Ghdlxml;
+-- with Ghdlsynth;
with Ortho_Jit;
procedure Ghdl_Jit is
@@ -34,6 +35,7 @@ begin
Ghdlprint.Register_Commands;
Ghdlvpi.Register_Commands;
Ghdlxml.Register_Commands;
+ -- Ghdlsynth.Register_Commands;
Ghdlmain.Register_Commands;
Ghdlmain.Main;
end Ghdl_Jit;