aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2019-11-20 07:22:59 +0100
committerTristan Gingold <tgingold@free.fr>2019-11-20 07:52:43 +0100
commit65abd669b8cdeff955a5c4264c99a97110cd8a93 (patch)
tree2a08a4911f4d4b38c459950043947cedb14b370c
parent7b3afe306288b6486ae76452af7ddb34f81ffcd2 (diff)
downloadghdl-65abd669b8cdeff955a5c4264c99a97110cd8a93.tar.gz
ghdl-65abd669b8cdeff955a5c4264c99a97110cd8a93.tar.bz2
ghdl-65abd669b8cdeff955a5c4264c99a97110cd8a93.zip
Makefile: fix build of ghdl_gcc with synth.
-rw-r--r--Makefile.in1
-rw-r--r--dist/gcc/Make-lang.in7
2 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index a49d07dc5..5dfce590c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -232,6 +232,7 @@ copy-sources.gcc: version.ads
$(CP) -p $(srcdir)/src/grt/grt-fcvt.ad? $(gcc_vhdl_dir)
$(CP) -p $(srcdir)/src/grt/grt-algos.ad? $(gcc_vhdl_dir)
$(CP) -p $(srcdir)/src/grt/grt-vstrings.ad? $(gcc_vhdl_dir)
+ $(CP) -p $(srcdir)/src/grt/grt-cstdio.c $(gcc_vhdl_dir)
$(CP) -p $(srcdir)/src/grt/grt-stdio.ad? $(gcc_vhdl_dir)
$(CP) -p $(srcdir)/src/grt/grt-table.ad? $(gcc_vhdl_dir)
$(CP) -p $(srcdir)/src/grt/grt-files_operations.ad? $(gcc_vhdl_dir)
diff --git a/dist/gcc/Make-lang.in b/dist/gcc/Make-lang.in
index beb8bbab2..f6b0acd2a 100644
--- a/dist/gcc/Make-lang.in
+++ b/dist/gcc/Make-lang.in
@@ -110,11 +110,14 @@ vhdl/default_paths.ads: Makefile
echo "end Default_Paths;" >> tmp-dpaths.ads
$(srcdir)/../move-if-change tmp-dpaths.ads $@
+GHDL_GRT_OBJS=vhdl/grt-cstdio.o
+
# The driver for ghdl. Depends on ghdl1 to use object files in vhdl/ subdir.
-ghdl$(exeext): ghdl1$(exeext) vhdl/default_paths.ads force
+ghdl$(exeext): ghdl1$(exeext) $(GHDL_GRT_OBJS) vhdl/default_paths.ads force
$(GNATMAKE) -o $@ -aI$(srcdir)/vhdl -aI$(srcdir)/vhdl/ghdldrv \
-aIvhdl -aOvhdl ghdl_gcc \
- -bargs -E -cargs $(ADA_CFLAGS) $(GHDL_ADAFLAGS) -largs $(LIBS)
+ -bargs -E -cargs $(ADA_CFLAGS) $(GHDL_ADAFLAGS) \
+ -largs $(GHDL_GRT_OBJS) $(LIBS)
# Build hooks: