aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2017-12-19 18:10:19 +0100
committerTristan Gingold <tgingold@free.fr>2017-12-21 07:36:46 +0100
commita8914d76b56ded8baed27d7a5a77b783191cfa9a (patch)
tree3a511b0e310304e8fcbfcaac4f939c06470d386e
parent53829efd96276a1cfd1b249cfc7cb53c549fda73 (diff)
downloadghdl-a8914d76b56ded8baed27d7a5a77b783191cfa9a.tar.gz
ghdl-a8914d76b56ded8baed27d7a5a77b783191cfa9a.tar.bz2
ghdl-a8914d76b56ded8baed27d7a5a77b783191cfa9a.zip
Makefile: Add install.vpi.local and mention it.
-rw-r--r--Makefile.in5
-rw-r--r--doc/building/gcc/index.rst2
2 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index d2e1463ff..91a42d0d4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -405,6 +405,11 @@ install.vpi: all.vpi install.dirs
$(INSTALL_DATA) -p libghdlvpi$(SOEXT) $(DESTDIR)$(libdir)/
$(INSTALL_DATA) -p $(GRTSRCDIR)/vpi_user.h $(DESTDIR)$(incdir)/
+install.vpi.local: all.vpi
+ $(MKDIR) -p include lib
+ $(INSTALL_DATA) -p $(GRTSRCDIR)/vpi_user.h include/
+ $(INSTALL_DATA) -p libghdlvpi$(SOEXT) lib/
+
################ Libraries ###############################################
LIBSRC_DIR:=$(srcdir)/libraries
diff --git a/doc/building/gcc/index.rst b/doc/building/gcc/index.rst
index 2b6e33c8c..5d76e1684 100644
--- a/doc/building/gcc/index.rst
+++ b/doc/building/gcc/index.rst
@@ -23,7 +23,7 @@ GCC Backend
$ make ghdl_gcc # Build the driver
$ make libs.vhdl.local_gcc # Compile the vhdl libraries
$ make grt-all # Build the GHDL runtime
- $ make grt.links # Locally install the GHDL runtime
+ $ make install.vpi.local # Locally install vpi files
In ``src/ortho/gcc``, create a ``Makefile.conf`` file that sets the following
variables: