aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2019-04-24 20:45:17 +0200
committerTristan Gingold <tgingold@free.fr>2019-04-24 21:47:06 +0200
commitf4689c2660cb26e341f79f8104d46c808427f6c0 (patch)
tree83cfa80d2f8ff98dc5df03f214614f6164ffb519
parent221abeb379c1c488c3b3bcda2dbb99a977ac90e9 (diff)
downloadghdl-f4689c2660cb26e341f79f8104d46c808427f6c0.tar.gz
ghdl-f4689c2660cb26e341f79f8104d46c808427f6c0.tar.bz2
ghdl-f4689c2660cb26e341f79f8104d46c808427f6c0.zip
libraries: rename _body files.
Fix #699
-rw-r--r--dist/windows/compile-libraries.ps114
-rw-r--r--dist/windows/mcode/complib.bat10
-rw-r--r--libraries/Makefile.inc12
-rw-r--r--libraries/ieee/std_logic_1164-body.vhdl (renamed from libraries/ieee/std_logic_1164_body.vhdl)0
-rw-r--r--libraries/mentor/std_logic_arith-body.vhdl (renamed from libraries/mentor/std_logic_arith_body.vhdl)0
-rw-r--r--libraries/std/env-body.vhdl (renamed from libraries/std/env_body.vhdl)0
-rw-r--r--libraries/std/textio-body.vhdl (renamed from libraries/std/textio_body.vhdl)0
-rw-r--r--libraries/vital95/vital_primitives-body.vhdl (renamed from libraries/vital95/vital_primitives_body.vhdl)0
-rw-r--r--libraries/vital95/vital_timing-body.vhdl (renamed from libraries/vital95/vital_timing_body.vhdl)0
9 files changed, 18 insertions, 18 deletions
diff --git a/dist/windows/compile-libraries.ps1 b/dist/windows/compile-libraries.ps1
index 95f793b8a..a37b78618 100644
--- a/dist/windows/compile-libraries.ps1
+++ b/dist/windows/compile-libraries.ps1
@@ -122,10 +122,10 @@ $GHDLNewExecutable = "$GHDLRootDir\$BuildDirectoryName\$Backend\bin\ghdl.
# Library sources
$SourceFiles = @{
"std" = @(
- "textio", "textio_body"
+ "textio", "textio-body"
);
"ieee" = @(
- "std_logic_1164", "std_logic_1164_body",
+ "std_logic_1164", "std_logic_1164-body",
"numeric_std", "numeric_std-body",
"numeric_bit", "numeric_bit-body"
);
@@ -134,8 +134,8 @@ $SourceFiles = @{
"math_complex", "math_complex-body"
);
"std08" = @(
- "textio", "textio_body",
- "env", "env_body"
+ "textio", "textio-body",
+ "env", "env-body"
);
"ieee2008" = @(
"std_logic_1164", "std_logic_1164-body",
@@ -155,8 +155,8 @@ $SourceFiles = @{
"ieee_bit_context"
);
"vital95" = @(
- "vital_timing", "vital_timing_body",
- "vital_primitives", "vital_primitives_body"
+ "vital_timing", "vital_timing-body",
+ "vital_primitives", "vital_primitives-body"
);
"vital2000" = @(
"timing_p", "timing_b",
@@ -173,7 +173,7 @@ $SourceFiles = @{
"std_logic_misc", "std_logic_misc-body"
);
"mentor" = @(
- "std_logic_arith", "std_logic_arith_body"
+ "std_logic_arith", "std_logic_arith-body"
)
}
diff --git a/dist/windows/mcode/complib.bat b/dist/windows/mcode/complib.bat
index 91504a832..e7291ad03 100644
--- a/dist/windows/mcode/complib.bat
+++ b/dist/windows/mcode/complib.bat
@@ -10,18 +10,18 @@ set LIBSRC=%REL%\..\..\libraries
::
:: library sources
::
-set STD_SRCS= textio textio_body
-set IEEE_SRCS= std_logic_1164 std_logic_1164_body numeric_std numeric_std-body numeric_bit numeric_bit-body
+set STD_SRCS= textio textio-body
+set IEEE_SRCS= std_logic_1164 std_logic_1164-body numeric_std numeric_std-body numeric_bit numeric_bit-body
set MATH_SRCS= math_real math_real-body math_complex math_complex-body
-set STD08_SRCS= textio textio_body env env_body
+set STD08_SRCS= textio textio-body env env-body
set IEEE08_SRCS= std_logic_1164 std_logic_1164-body std_logic_textio math_real math_real-body math_complex math_complex-body numeric_bit numeric_bit-body numeric_bit_unsigned numeric_bit_unsigned-body numeric_std numeric_std-body numeric_std_unsigned numeric_std_unsigned-body fixed_float_types fixed_generic_pkg fixed_generic_pkg-body fixed_pkg float_generic_pkg float_generic_pkg-body float_pkg ieee_bit_context ieee_std_context
-set VITAL95_SRCS= vital_timing vital_timing_body vital_primitives vital_primitives_body
+set VITAL95_SRCS= vital_timing vital_timing-body vital_primitives vital_primitives-body
set VITAL2000_SRCS= timing_p timing_b prmtvs_p prmtvs_b memory_p memory_b
set SYNOPSYS_SRCS= std_logic_arith std_logic_textio std_logic_unsigned std_logic_signed std_logic_misc std_logic_misc-body
-set MENTOR_SRCS= std_logic_arith std_logic_arith_body
+set MENTOR_SRCS= std_logic_arith std_logic_arith-body
mkdir lib
diff --git a/libraries/Makefile.inc b/libraries/Makefile.inc
index f9f8e8c4d..c4bb87643 100644
--- a/libraries/Makefile.inc
+++ b/libraries/Makefile.inc
@@ -42,23 +42,23 @@ vhdl.libs.v93: std.v93 ieee.v93 synopsys.v93
vhdl.libs.v08: std.v08 ieee.v08
endif
-STD_SRCS := std/textio.vhdl std/textio_body.vhdl
+STD_SRCS := std/textio.vhdl std/textio-body.vhdl
SYNOPSYS_BSRCS := synopsys/std_logic_arith.vhdl \
synopsys/std_logic_unsigned.vhdl \
synopsys/std_logic_signed.vhdl
SYNOPSYS_V_BSRCS := synopsys/std_logic_misc.vhdl \
synopsys/std_logic_misc-body.vhdl
SYNOPSYS8793_BSRCS := synopsys/std_logic_textio.vhdl
-MENTOR_BSRCS := mentor/std_logic_arith.vhdl mentor/std_logic_arith_body.vhdl
+MENTOR_BSRCS := mentor/std_logic_arith.vhdl mentor/std_logic_arith-body.vhdl
ifeq ($(enable_openieee),false)
-IEEE_SRCS := ieee/std_logic_1164.vhdl ieee/std_logic_1164_body.vhdl \
+IEEE_SRCS := ieee/std_logic_1164.vhdl ieee/std_logic_1164-body.vhdl \
ieee/numeric_bit.vhdl ieee/numeric_bit-body.vhdl \
ieee/numeric_std.vhdl ieee/numeric_std-body.vhdl
MATH_SRCS := ieee/math_real.vhdl ieee/math_real-body.vhdl \
ieee/math_complex.vhdl ieee/math_complex-body.vhdl
-VITAL95_BSRCS := vital95/vital_timing.vhdl vital95/vital_timing_body.vhdl \
- vital95/vital_primitives.vhdl vital95/vital_primitives_body.vhdl
+VITAL95_BSRCS := vital95/vital_timing.vhdl vital95/vital_timing-body.vhdl \
+ vital95/vital_primitives.vhdl vital95/vital_primitives-body.vhdl
VITAL2000_BSRCS := vital2000/timing_p.vhdl vital2000/timing_b.vhdl \
vital2000/prmtvs_p.vhdl vital2000/prmtvs_b.vhdl \
vital2000/memory_p.vhdl vital2000/memory_b.vhdl
@@ -93,7 +93,7 @@ ANALYZE_DEP=$(GHDL)
STD87_BSRCS := $(STD_SRCS:.vhdl=.v87)
STD93_BSRCS := $(STD_SRCS:.vhdl=.v93)
-STD08_BSRCS := $(STD_SRCS:.vhdl=.v08) std/env.vhdl std/env_body.vhdl
+STD08_BSRCS := $(STD_SRCS:.vhdl=.v08) std/env.vhdl std/env-body.vhdl
IEEE87_BSRCS := $(IEEE_SRCS:.vhdl=.v87)
IEEE93_BSRCS := $(IEEE_SRCS:.vhdl=.v93) $(MATH_SRCS)
SYNOPSYS87_BSRCS := $(SYNOPSYS_BSRCS) $(SYNOPSYS_V_BSRCS) $(SYNOPSYS8793_BSRCS)
diff --git a/libraries/ieee/std_logic_1164_body.vhdl b/libraries/ieee/std_logic_1164-body.vhdl
index 88a87482c..88a87482c 100644
--- a/libraries/ieee/std_logic_1164_body.vhdl
+++ b/libraries/ieee/std_logic_1164-body.vhdl
diff --git a/libraries/mentor/std_logic_arith_body.vhdl b/libraries/mentor/std_logic_arith-body.vhdl
index 36f76cb7d..36f76cb7d 100644
--- a/libraries/mentor/std_logic_arith_body.vhdl
+++ b/libraries/mentor/std_logic_arith-body.vhdl
diff --git a/libraries/std/env_body.vhdl b/libraries/std/env-body.vhdl
index d36519fc9..d36519fc9 100644
--- a/libraries/std/env_body.vhdl
+++ b/libraries/std/env-body.vhdl
diff --git a/libraries/std/textio_body.vhdl b/libraries/std/textio-body.vhdl
index d01cb8bad..d01cb8bad 100644
--- a/libraries/std/textio_body.vhdl
+++ b/libraries/std/textio-body.vhdl
diff --git a/libraries/vital95/vital_primitives_body.vhdl b/libraries/vital95/vital_primitives-body.vhdl
index f8f66366c..f8f66366c 100644
--- a/libraries/vital95/vital_primitives_body.vhdl
+++ b/libraries/vital95/vital_primitives-body.vhdl
diff --git a/libraries/vital95/vital_timing_body.vhdl b/libraries/vital95/vital_timing-body.vhdl
index 49998bdb5..49998bdb5 100644
--- a/libraries/vital95/vital_timing_body.vhdl
+++ b/libraries/vital95/vital_timing-body.vhdl