aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author1138-4EB <1138-4EB@users.noreply.github.com>2019-06-17 07:57:59 +0200
committertgingold <tgingold@users.noreply.github.com>2019-06-17 07:57:59 +0200
commitf6379989022c1e71017f4151392a300534d2007a (patch)
tree783ba27543a32a5c009a5cdc92952809a1436728
parent159e0bfdbb135e74aac10e54c7a499e9e34aa5a2 (diff)
downloadghdl-f6379989022c1e71017f4151392a300534d2007a.tar.gz
ghdl-f6379989022c1e71017f4151392a300534d2007a.tar.bz2
ghdl-f6379989022c1e71017f4151392a300534d2007a.zip
fix: move src/xtools to python/xtools (#846)
* fix: move src/xtools to python/xtools * fix Makefiles affected by xtools and pnodes being moved
-rwxr-xr-xpython/xtools/pnodes.py (renamed from src/xtools/pnodes.py)0
-rw-r--r--src/edif/Makefile2
-rw-r--r--src/psl/Makefile2
-rw-r--r--src/vhdl/Makefile4
4 files changed, 4 insertions, 4 deletions
diff --git a/src/xtools/pnodes.py b/python/xtools/pnodes.py
index 62d5362d3..62d5362d3 100755
--- a/src/xtools/pnodes.py
+++ b/python/xtools/pnodes.py
diff --git a/src/edif/Makefile b/src/edif/Makefile
index 7d2fa6980..3a3cb4a8b 100644
--- a/src/edif/Makefile
+++ b/src/edif/Makefile
@@ -6,7 +6,7 @@ ortho_srcdir=../ortho
GEN_SRCS=edif-nodes.adb edif-nodes_meta.ads edif-nodes_meta.adb
CC=gcc
-PNODES=../xtools/pnodes.py
+PNODES=../../python/xtools/pnodes.py
PNODES_ARGS=--field-file=edif-nodes.adb.in --kind-file=edif-nodes.ads --node-file=edif-nodes.ads --template-file=edif-nodes.adb.in --meta-basename=edif-nodes_meta --kind-type=Nkind --kind-range-prefix=Nkinds_ --kind-prefix=N_ --node-type=Node
all: dump_edif
diff --git a/src/psl/Makefile b/src/psl/Makefile
index 472a82b01..fdcfccaf7 100644
--- a/src/psl/Makefile
+++ b/src/psl/Makefile
@@ -20,7 +20,7 @@
# be committed and distribued with the sources, so that users don't need to
# regenerate them (and don't need to have python installed).
-PNODES=../xtools/pnodes.py
+PNODES=../../python/xtools/pnodes.py
DEPS=psl-nodes.ads psl-nodes.adb.in $(PNODES)
diff --git a/src/vhdl/Makefile b/src/vhdl/Makefile
index 425563a18..3f09c855f 100644
--- a/src/vhdl/Makefile
+++ b/src/vhdl/Makefile
@@ -20,8 +20,8 @@
# be committed and distribued with the sources, so that users don't need to
# regenerate them (and don't need to have python installed).
-PNODES=../xtools/pnodes.py
-PNODESPY=python/pnodespy.py
+PNODES=../../python/xtools/pnodes.py
+PNODESPY=../../python/pnodes/pnodespy.py
DEPS=vhdl-nodes.ads vhdl-nodes.adb.in $(PNODES)