aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2014-11-19 13:53:17 +0100
committerTristan Gingold <tgingold@free.fr>2014-11-19 13:53:17 +0100
commit2339d9c6df8c73d01667afa4d1bd938ea98b71d8 (patch)
treef5e284426978f1beba0c5d066973788d90309905 /Makefile.in
parent35e032570cb36b731f80b4b30812199669695abc (diff)
downloadghdl-2339d9c6df8c73d01667afa4d1bd938ea98b71d8.tar.gz
ghdl-2339d9c6df8c73d01667afa4d1bd938ea98b71d8.tar.bz2
ghdl-2339d9c6df8c73d01667afa4d1bd938ea98b71d8.zip
Makefile.in: allow parallel compilation of std.standard.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/Makefile.in b/Makefile.in
index ca8a7b6b1..84761de91 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -229,30 +229,30 @@ $(LIB93_DIR)/std/std_standard.o: $(GHDL1)
ifeq ($(GHDL),ghdl_llvm)
$(GHDL1) --std=93 -quiet $(LIB_CFLAGS) -c -o $@ --compile-standard
else
- $(GHDL1) --std=93 -quiet $(LIB_CFLAGS) -o std_standard.s \
+ $(GHDL1) --std=93 -quiet $(LIB_CFLAGS) -o std_standard_93.s \
--compile-standard
- $(CC) -c -o $@ std_standard.s
- $(RM) std_standard.s
+ $(CC) -c -o $@ std_standard_93.s
+ $(RM) std_standard_93.s
endif
$(LIB87_DIR)/std/std_standard.o: $(GHDL1)
ifeq ($(GHDL),ghdl_llvm)
$(GHDL1) --std=87 -quiet $(LIB_CFLAGS) -c -o $@ --compile-standard
else
- $(GHDL1) --std=87 -quiet $(LIB_CFLAGS) -o std_standard.s \
+ $(GHDL1) --std=87 -quiet $(LIB_CFLAGS) -o std_standard_87.s \
--compile-standard
- $(CC) -c -o $@ std_standard.s
- $(RM) std_standard.s
+ $(CC) -c -o $@ std_standard_87.s
+ $(RM) std_standard_87.s
endif
$(LIB08_DIR)/std/std_standard.o: $(GHDL1)
ifeq ($(GHDL),ghdl_llvm)
$(GHDL1) --std=08 -quiet $(LIB_CFLAGS) -c -o $@ --compile-standard
else
- $(GHDL1) --std=08 -quiet $(LIB_CFLAGS) -o std_standard.s \
+ $(GHDL1) --std=08 -quiet $(LIB_CFLAGS) -o std_standard_08.s \
--compile-standard
- $(CC) -c -o $@ std_standard.s
- $(RM) std_standard.s
+ $(CC) -c -o $@ std_standard_08.s
+ $(RM) std_standard_08.s
endif
libs.vhdl.v93: std.v93 ieee.v93 synopsys.v93 mentor.v93