aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorAndreas Bombe <aeb@debian.org>2021-10-03 17:19:56 +0200
committertgingold <tgingold@users.noreply.github.com>2021-10-04 07:24:42 +0200
commit23b2ab60ed68afc91fc68aafaf4ad54efcead307 (patch)
tree856a76cedbd3f7819a4ca583c7b219d7b0468f81 /Makefile.in
parent3b89246729436bbedc955eb34074f2143fc8feb2 (diff)
downloadghdl-23b2ab60ed68afc91fc68aafaf4ad54efcead307.tar.gz
ghdl-23b2ab60ed68afc91fc68aafaf4ad54efcead307.tar.bz2
ghdl-23b2ab60ed68afc91fc68aafaf4ad54efcead307.zip
Makefile.in: Use $(CURDIR) instead of $(shell pwd)
GNU make will set the variable CURDIR to the current directory, there is no need to call out to the shell. Also use simple assignment instead of conditional on not previously set. Otherwise it could get its value from an envirnoment variable "PWD", which shells may or may not have set, or which may not be up to date at the time of the call.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 7e7f6b8f1..007879e70 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -46,7 +46,7 @@ default_pic=@default_pic@
INSTALL_PROGRAM=install -m 755
INSTALL_DATA=install -m 644
-PWD?=$(shell pwd)
+PWD=$(CURDIR)
DESTDIR=
bindir=$(prefix)/bin
libdir=$(prefix)/lib