aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2023-01-16 21:51:09 +0100
committerTristan Gingold <tgingold@free.fr>2023-01-16 21:51:09 +0100
commit4f049968ed5b09b28fa6f7642129bf519ae495b1 (patch)
tree32474feb7b1b1272d4d65c28c1a347c8a03aa3a2 /Makefile.in
parent27812b602d2dfc452895c156bf0376bdcda71c8c (diff)
downloadghdl-4f049968ed5b09b28fa6f7642129bf519ae495b1.tar.gz
ghdl-4f049968ed5b09b28fa6f7642129bf519ae495b1.tar.bz2
ghdl-4f049968ed5b09b28fa6f7642129bf519ae495b1.zip
Makefile.in: add a recipe for python-bwheel
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in33
1 files changed, 31 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 8b19c5e7e..29b6bb1ae 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -225,7 +225,7 @@ uninstall.mcode.program:
install.mcode: install.mcode.program install.vhdllib
-install.mcode.dll_deps:
+install.mcode.deps.dll:
for f in $$(ldd ghdl_mcode$(EXEEXT) | sed -n -e '/Windows/d' -e 's/.*=> \(.*\) .*/\1/p'); do \
$(INSTALL_PROGRAM) -p $$f "$(DESTDIR)$(bindir)/"; \
done
@@ -509,11 +509,14 @@ install.libghdl.true: install.libghdl.lib install.libghdl.include
install.libghdl.false:
install.libghdl: install.libghdl.$(enable_libghdl)
-install.libghdl.dll_deps:
+install.libghdl.deps.dll:
for f in $$(ldd lib/$(libghdl_name) | sed -n -e '/Windows/d' -e 's/.*=> \(.*\) .*/\1/p'); do \
$(INSTALL_PROGRAM) -p $$f "$(DESTDIR)$(libdir)/"; \
done
+install.libghdl.deps.dylib:
+install.libghdl.deps.so:
+
uninstall.libghdl:
$(RM) $(DESTDIR)$(libdir)/$(libghdl_name)
@@ -657,6 +660,32 @@ install.vhdllib: install.dirs
uninstall.vhdllib:
$(RM) -rf $(DESTDIR)$(VHDL_LIB_DIR)
+####################### pyGHDL standalone ################################
+
+setup-standalone.py: $(srcdir)/setup-standalone.in
+ ( \
+ sed -n -e '1,/^#@__init__/p' < $<; \
+ sed -n -e '/__author__/,/^$$/p' < $(srcdir)/pyGHDL/__init__.py; \
+ echo 'srcdir = "$(srcdir)"' ; \
+ echo 'soext = "$(SOEXT)"'; \
+ sed -n -e '/^#@__init__/,$$p' < $< ; \
+ ) > $@
+
+python-bwheel: setup-standalone.py lib/$(libghdl_name) libs install.libghdl.deps$(SOEXT)
+ rm -rf dist-wheel
+ mkdir dist-wheel
+# Copy pyGHDL
+ $(CP) -Rp $(srcdir)/pyGHDL dist-wheel/
+# Copy libraries
+ for d in $(VHDLLIB_SUBDIRS); do \
+ $(MKDIR) -p dist-wheel/pyGHDL/lib/ghdl/$$d; \
+ $(INSTALL_DATA) -p \
+ $(LIBDST_DIR)/$$d/* dist-wheel/pyGHDL/lib/ghdl/$$d; \
+ done
+# Copy libghdl
+ $(INSTALL_PROGRAM) -p lib/lib*$(SOEXT) dist-wheel/pyGHDL/lib/
+
+
####################### clean ############################################
clean: force